[RELEASE] HubConnect - Share Devices across Multiple Hubs (even SmartThings!)

I thought you were asking about the Ring Extender version. My bad. I have HC 2.0 so this should work thanks!!! I will work on this today and let you know if I have trouble.

So I finished my ST to HE migration, the only Things on ST are my Echos, and the only SmartApps are Echo Speaks, HubConnect, and (an Empty) WebCore.

I have automations on HE using Echo Speaks to talk, working great. Is there documentation to follow to remove my physical ST hub? Can I just power it off? I wasn't sure if there was a migration to continue to use the ST portal, and my setup without the physical hub.

Thanks

@bfara83 got the Ring RE to work after following your instructions, thank you.

In trying to get my Aeotec HEM to work I installed the driver for it on the hub (not an HC driver I did not find one), and wrote the custom driver below. when I select the device on the remote hub and save. I get the following error and no device is created. I think it is due to no custom driver for the device. any thoughts?

Are you able to post the driver you wrote so I can see what is causing the error? It maybe missing something on one of the attributes like the "number" or "string" on the end in the driver.

I am using the driver post here. But I think that is the issue I have no clue how to begin the process of making my own.

How you are setting up the Custom Driver looks fine on your screenshot, see if this driver works for you:

same, error.

Do I need delete and rebuild it inside HC now that your driver is installed? tried, same error.

@csteele @srwhite

I'm getting the same error on HC 2.0 but can't figure out what would be causing it using the same device and driver I created above.

Do you know what is causing error on this one, line 577 on HubConnect Remote App has this:

Using the default HubConnect Power Meter driver works fine with this same driver/device.

1 Like

my error is on line 418 above if that matters.

I'm having an HSM syncing problem between my hubitat hub and homebridge that I was hoping someone could help me with. I feel like I'm missing a key step somewhere.

I'm able to push HSM changes from hubitat and that will sync with homebridge. But it doesn't seem to work the other way around. When switching modes in the Home app, it just gets stuck "Arming".

I also wanted to add that I have turned on this field in the hubconnect app settings:
Synchronize HSM status from this remote (client) hub to the Server hub.
Receive HSM changes from Remote Hub?

And the homebridge-hubitat-hubconnect config hsm setting is set to true: "hsm": true,

Thank you!

Which version of HubConenct, please? v1.6.4 or v2.0RC1?

I’m using 2.0rc1. It seems like everything works except for the HSM.

Can you try an experiment for me, please? It's a one word change...

Server Instance Code, approx line 724:

String hsmState = (localConnectionType == "socket") ? params.value : (params?.name ? URLDecoder.decode(params?.name) : "")

Please change the word "value" to be "name"

String hsmState = (localConnectionType == "socket") ? params.name : (params?.name ? URLDecoder.decode(params?.name) : "")

2 Likes

Quick HC question. If I change the name of a device connected to a remote hub is it possible to push that new name to the master hub or do I have to manually rename each?

Yes, manual. :slight_smile:

There's no requirement that it match from a 'computer' viewpoint. We humans would prefer they match. True.

EDIT: I thought that you could do this, but if @csteele says you can't - you probably can't...

Original text:
After you change the name, go through the same process you would to add a device, but just don't add anything. (I think you'll have to click on "done" up to the point where you are back to the Hubitat Apps screen.) I remember seeing this question in this thread before, it should be as easy to find as a needle in a hay stack at this point... :wink:

Ah thank you! That worked. HSM states change instantly from Home app now.

3 Likes

I'm having trouble duplicating this one... As always, I believe you're seeing an error, what I can't do is click the right things to get it to happen here.

Your hints are: it's on a Remote hub, so the 'real device' is implied to be on the Server. That's being mirrored to the remote, which needs the custom driver.

I created a custom device per the screen cap and deployed the driver. Is that all you do to get the error?

@csteele

Sorry I didn't specify, for me the real device is on a remote hub and trying to add to the Server hub. The funny thing is I tried it again after trying it several times many different ways on Friday and it worked now.

@TechMedX, here's how I did it.

  1. Added the driver here on my post above on the Server: [RELEASE] HubConnect - Share Devices across Multiple Hubs (even SmartThings!)

  2. Add a Custom Driver on Server doing the following:
    image

  3. Attributes match the driver exactly with powerMeter being primary attribute then Save Driver.

Update: Add "energy" as attribute too, forgot to add it till afterwards.

  1. On Remote hub where real device is, on HubConnect Remote Client App add the device with the Custom Driver that was made above.

  1. Now this device is added on the Server Hub:
1 Like

@bfara83 @csteele I set it up exactly as you have there, and I still get error on 418 :frowning_face:

Download the Hubitat app