[RELEASE] Home Assistant Device Bridge (HADB)

Thanks for considering, and I can understand if it doesn’t quite work to include certain device types, including a media player/music player.

I just started looking into the Denon HEOS integration in HA.

Technically, there is a Hubitat integration, but it’s one of @dman2306’s apps, which means it’s no longer supported.

It’s still working but I was just trying to stay ahead of any issues in case an update in the future either on the Hubitat or HEOS end introduces a breaking change.

Another good one is Apple TVs and HomePod minis (they're both using the same pyatv framework in HA). The HomePod mini can be used for TTS in HA. The Apple TV can be tuned to a specific streaming service via HA's integration. I imagine the HomePod mini might be a bit more straightforward.

Yes, and whats more interesting, If I use home assistants outside ip https://, and I check "require secure connection, it works. But I cant get it to work on the local IP.
Not using secure connection on the local, I just keep getting websocket error

Is the local IP of your HA setup routable from your Hubitat hub?

It should be, its on the same network, now HA it running on a nuc in docker, but I can hit it from any machine on my network. I just selected debug in he and the message is "no route to host (host unreachable) which is so strange. Is there a way for me to ping from inside HE?

This is a wrapper for ping from Hubitat. Maybe give it a try? [Release] Hubitat Ping

1 Like

I will, here is my setup, i have tried with and without http://

Is the port correct, given how you have it hosted in Docker? Maybe you need to forward a port in Docker and/or use a different port in the Hubitat app config.

Yea, all the forwarding is done in my docker compose, The ip is pingable from hubitat using hubitat ping that you sent me.

That is odd. I am out of my depth with Docker in this case. @bradford.clarke mentioned earlier in this thread that he runs HA in Docker and was successfully using HADB. Can you share any tips on what it takes to get it working, @bradford.clarke?

@tomw @beyondunreal

I just checked my HA configuration in Portainer (i run my containers within Open Media Vault on my Pi based NAS) and the only thing i seem to recall having to tweak was to make sure HA was set up on the host network and not as a bridge.

1 Like

I figured it out. The HE hub's local IP address was banned in HA ip_bans.yaml. I cleared that out, restarted HA and it connected!


Version 0.1.50 comes with an option to ignore unavailable or unknown states as discussed earlier and improved lights support.


Please advise how to resolve the error below.

parsing error


Please install the following driver.


Great, this driver worked, the error is now gone.

1 Like

It seems like maybe we should make that driver required in HPM and also mention it in the manual install instructions. Or else just handle that error more gracefully. What do you think @ymerj?


Making the component required is a way to handle the error more gracefully :wink:


Just here to say thank you for this integration. You have made me retake my backburner project and breadth new life into it. I have thoroughly enjoyed and destroyed/redesigned my whole infra at home, lol. Keep up this magnificent work. If you'd allow me to suggest, a search box while selecting the entities would be swell, but not a deal breaker for me either.


Cool, I agree. I made that change in the HPM manifest.

Anyone who wants to pick up that change immediately should Repair the HADB package in HPM.

It's not urgent for most people, though, so the next Upgrade would presumably also pick up this change also.