[Release] Fan Thermostat with manual override

Thank you very much. It took me a while to figure out how to load the software, I am a layer 1 guy, but it looks like it loaded and was installed correctly. I will let you know.

I was able to reset one fan so, I am experiencing with that one. The app is loaded and the temp is reporting. Where do I set the temp/speed?
Thanks again,

I found it and it looks like it works!

Next question. If I change the fan controller to the one that is communicating with the app to another fan with the same frequency, will they
both change?

I must be doing something wrong in the setup. The fan speed does not change.

Every fan controller you connect to Hubitat should work independently. You can configure this app to control multiple fans with a single virtual thermostat if you want, or you can create a separate thermostat per fan. That's up to you. I personally do the latter since different rooms in my house tend to be different temperatures.

Do you mean you can't control the fan speed manually in Hubitat, or the app isn't automatically changing the speed as the temperature changes? If the former then you may want to start a thread in the general help section of this forum. If the latter, post a screenshot of the Fan Thermostat app settings page and the thermostat device page and maybe I can give some advice.

Thank you for getting back to me. I think I don't have the temperature set up correctly. so, the fan speed doesn't change.

The fan device page itself isn't very useful for diagnosing what's wrong. I would need screenshots of your "Dining Room Fan Thermostat" device and application.

It is working. I will send an apology and what I did wrong tomorrow.
Thank you for a great APP!

Sorry, I forgot the"what went wrong". I didn't realize that you had to push the button above where you entered the settings to "enter" them in programming. Thank you, it's been working flawlessly.
Feature request: Any chance to do temperature and humidity?

I am having trouble setting up my 6 speed fans that are created with the built-in Bond Integration. The integration creates a speed “very-low” for speed 1 that does not show up as a value in the Set Speed attribute pulldown on the device screen, in RM or as a speed option when setting up a Fan Thermostat in your App. I can set the “very-low” speed using Custom Commad in RM.

Is there a way to have your App support “very-low” as one of the speed options as that lowest speed is the one I would like the Thermostat to kick on first?

Please see the following on this topic also regarding the missing speeds on the attribute drop down:

Hmm, Hubitat's FanControl device capability pretty explicitly only supports the 5 speeds that this app allows you to select (plus on, off, and auto).

I could see about adding a toggle to replace the checkbox selector with a freeform text entry so you could just input a comma-separated list of speeds for such non-conforming devices though.

Edit: Done. Update to version 1.8 and turn on the new "Use Non-Standard Fan Speeds" toggle. Let me know if there are any problems.

1 Like

Wow! Thanks that works.

I don’t know if this is nonstandard now as this is a Fan Device that is created by the Hubitat developed Bond Integration, but I understand that point from your perspective and I so appreciate the incredibly fast response and solution!n.

It feels like the HE team chose a bit of hack to support fans through the Bond Integration that have more than 5 speeds. I also get it that they probably do not want to prioritize refactoring the Fan Control Device at this time given how few of us have fans with more than 5 speeds. It is probably the right decision, but I wish they had not made accessing my lowest speed the one not supported by the standard control as that is used all the time. I can live without the fastest as we never use speeds 5 & 6 anyways.

Thanks again! You are another great example of why this community is so great. Kudos to you!


Your fan thermostat is a great addition to the Hubitat and I have been enjoying it for several years now. I just performed the v1.8 update and suddenly my fan won't turn off when the measured temperature goes below the setpoint. I have done some testing and if I first put in cool mode when it is below, it turns the fan off. If I change the setpoint to raise it above the current temperature, it shuts the fan off. But, if it cools down to below the current temperature setpoint, it keep humming away on low. Any idea on how to correct that? Do I need to delete and setup the device again due to the new fan options available in v 1.8?

Thanks again for your work on this great code!


v1.8 should be fully compatible with existing setups. One thing I just noticed while testing is that if you turn on the "Use Non-Standard Fan Speeds" toggle, then turn it off again you'll need to make sure you click "Done" instead of just navigating away or it can get stuck in a bad state. If that's what happened, you can fix it by just opening the child app, re-selecting your "Participating Speeds" and clicking done.

Besides that, I'm not sure what could be happening. The first thing to do would be to check the logs for any errors relating to the fan device(s) being controlled, this app, or the thermostat child device it created.

Does this work with Lutron Caseta Fan switch for being able to select multiple speeds?

Anyone have a rule example for turning the point from cool to off? I want to set it up where if the outside temp is less then 60 degrees on my weather station that it turned the mode to off. Anything above and it sets it to cool.

Took a stab at this myself… can someone confirm whether this will work?

It should work with any device that fulfils Hubitat's "FanControl" capability. I don't have a Caseta fan switch, but I suspect it does.

That looks like it should work to me.