[RELEASE] Event Engine - Automate your world with easy to use Cogs. Rev up complex automations with just a few clicks!

hello all!

i have some sylvania bulbs and would like them to change with a fade if possible between christmas colors? i cant find how with this app can make it work

can somebody help?

Can't with this app but try Lighting effects found on my GitHub. Link is in my profile.

1 Like

good. i already installed it and setup it but doesnt start working?...

Jump over to the LE thread and post screenshots of how you have it setup.

New version on GitHub...

3.3.8 - 12/10/21 - Cosmetic fix for slow dimming down devices. Added Ring Keypad G2 to Actions (play tones!)

1 Like

New version on GitHub ...

3.3.9 - 12/11/21 - Update to Ring G2 Tone Options, Added Color Changing Actions

Had a few people looking for Lighting Effects type of color changing actions ... So it's now in EE!

1 Like

Christmas has come early. :smiley: Thank you!

1 Like

I'm still trying to set up the rule to dim my bedroom lights from 40% to 5% Begining at 2000.
Background:

  • The rule to turn them on and set them fires 30 minutes before sunset, (except on Tuesday and Wednesday).

  • The lamps in this group are set to 40%.
    When this rule fires, it bumps the brightness up to 99 for a minute or two then drops back to 40%, then starts to dim as intended .

If I read your response correctly this is what it should look like, but it still bumps up to 99 for a minute or two before dimming (negatively impacting WAF).

If I take out the Starting level, then it throws an error wanting something in that field

Am I missing something? I actually have two similar rules for different device groups, and both are behaving the same way.

Thanks!

I think I found it.

New version on GitHub...

3.4.0 - 12/12/21 - Fixed Slow Dimming actions

2 Likes

Just updated (via HPM) if I am, supposed to leave "Starting level" blank, then something is still off. it is still throwing errors if I remove that value.

Nope, that's a required field. Anything with an * Asterisk is required.

That's what I thought. So then, If I put the value from the other rule that turned on and set it (in this case would be 40%), when it fire with this update, should that stop it from that momentary bump up to 99%?

Make sure you don't have two Cogs fighting each other. Using Slow Dimming will turn the bulb on to whatever level you set it to and then start dimming.

Well, I think the brightening before dimming may be a device issue. I will pursue that further in that regard. Next Up, I have a cog to turn on and set to 3% a family room lamp (an Innr Zigbee bulb running on the Generic Advance Zogbee bulb driver) and 1 bedroom lamp (an Inovelli Zwave Multicolor LZW42 bulb) at 0500 and back off at 0600 on Saturday and Sunday only. The works well, however, it seems that it does not respect the days of the week. Even though it is set for Saturday and Sunday, this is firing every morning.
Here is the cog

And Here is the log from this morning.

There are no other rules or events that are supposed to fire at this time that includes these devices during the week.

Thanks!

On the 'By Days' Condition, turn the 'By Days As Restriction' to True

Thanks

Oh dang, I've been looking at that for a week and never caught it! Thanks!

1 Like

Nope, I checked the Restriction Toggle before I went to bed last night, still happened this morning. Also happened AGAIN at 0800 at full brightness. there are no rules for anything to fire at that time any day. I'm inclined to think this is something other than Event Engine. Is there anything that could be causing the errant commands to execute?

Only way to tell is to see a log.

Other than that, look at the device and scroll to the bottom. It'll tell what can control the bulb.

Hope this helps

I don't see anything in the logs other that it turning on and off
image

Do you mean "in use by"? Nothing there. That is why I was wondering what else could be causing this..

You'll need to turn on Debug Logging in the device page and wait for it to happen. Remember most drivers turn the debug log off after 30 minutes so you'll need to keep an eye on it. :wink:

2 Likes

Download the Hubitat app