[RELEASE] Eternal Sunshine (luminescence and dimmers)

I continue to love this app. Once the curve parameters are tweaked to my luminance sensor it works beautifully. One enhancement that would make it really nice would be a mode or time associated ability to dim the controlled lamps to a constant preset level. I am feeling the need to be able to dim the controlled lamps to a low level when everyone is in bed. Thanks so much for creating this fun and very cool app.

1 Like

Hi, and thanks for your great feedback. There is already such an option in the settings. Take a look and let me know if this is to your liking. I still have to work on the whole settings' overall layout, but it's all there. Just take a look! :slight_smile:

I have tried your newest version and am getting the below errors. I still have one of your previous versions installed working great. It is currently paused.

Hi, sorry for the delay, I'm in a middle of a moving. I think I found out what is causing this and pushed an update. If you still get an error message, please send a snapshot of your settings so I can investigate further and, also, enable the debug option in the settings so you can get more detailed logs.
Thank you for your precious feedback.

Seems to be working great. Just trying to figure out the logarithmic settings. Thanks

I installed this app for the first time last night and configured it to only work in the day time. Woke up this morning to find errors repeating in the log.

The first one I saw was this repeating in multiple of 5 min (sometimes every 5 min, sometimes every 10 min, etc).

I enabled the "These dimmers are turned off by another app", because they are controlled by my Pico remote that I have set up through the Button Controllers app. Not sure if that counts and if I should disable this option.

When I did turn the lights on via the Pico remote, I started seeing a different repeating error (every 1 min).

Here's how I have the app setup.

And I'm not sure if it matters, but my office lights is a group of 4 lights. Currently 2 of them are set to 50% and the other 2 are set to 100% brightness.

Lastly, have you considered adding your app to the Hubitat Package Manager? :slight_smile:

Thanks for the feedback. I’ll look into it very soon.

Hi,
I was able to reproduce the error message. It is due to the fact that you probably enabled the mode option "Differentiate Maximum Dimmer's Values With Location Mode", selected modes but did not define any value and then disabled the same mode option.

Thank you so much because this was a situation I should have expected in the code and now, thanks you to you, it's fixed.

I just pushed an update, everything should work now, fingers crossed! Let me know.

Elfege

Thanks for the quick turnaround!

I uninstalled the old version earlier today. So I had to reinstall the new version fresh. I didn't mess with the "Differentiate Maximum Dimmer's Values With Location Mode" option this time, so I don't think I'll get the error again. I'll let you know if I do encounter anything though.

I've been watching the illuminance go up on my sensor this morning and the lights dim down accordingly--sweet! I do see an intermittent error in the logs sometimes when the lux value changes, but it doesn't happen every time. For example:

But here's an illuminance change with no error:


Overall the app seems to be working now, so I'm not sure how big of a deal the error is. Let me know if you need more logging data for the error!

As for the sensitivity, I set the value to minimum (3.0) and I still think it's keeping my lights a bit higher then I'd like. I've started to mess around with the Advanced Logarithm Settings, but can you clarify what values I'm looking at for the graph helper (i.e. what are the x and y axes)? From the instructions it seems like the x-axis is the lux sensor value, so does that make the y-axis the light's dimmer level? I'm a bit confused on how to read the graph. :sweat_smile:

Hi, and thanks again for taking the time to try this app and to report.

I would need more debug data (enable debug in the app) but I think I was able to guess the cause of the error message. I just pushed an update. You'll need to go to the app and click "update" in order for this to work properly after you updated the code.

As for what regards your individual settings, it's quite impossible for me to help you since I don't have access to your configuration. However, I can suggest that you play around with the graph using the link provided in the app. If you read the full description in the app, that should help to.

X is the number of lumens reported by your sensor
Y is the desired dimmer values corresponding to lumens reported by your sensor

So, what you need to do, is run the cursors as to have the curve meet the x at the exact amount of lumens at which you want your lights to be off. If you want your lights to be set to a higher dimming value for a certain amount of lumens, move the cursor b, then adjust the other cursors a and c (go slowly, maybe even type your values manually instead of using the cursor) until it looks like it matches your needs. Then you just have to report the values in a, b and c fields into the app's settings.

If you need to start over, then just refresh the page on desmos.

Beware of the fact that everything depends on the maximum lumens your sensor may return. So, if you use the logarithm function, the "I don't know the maximum value" will be disabled in the last version I just updated.

usually, indoors values are rarely beyond 2000 lux and will mostly range at a max of 1000 lux, while outdoor values can go up to 15K lux or more. So it all depends on whether you're using an indoor or outdoor sensor/data source.

1 Like

I have an indoor Hue motion sensor and just took my brightest flashlight and shined it into it's illuminance sensor and it went up to 14,000+! :exploding_head: I'll put the max value for it as 15k. :grinning_face_with_smiling_eyes:

But in my everyday use so far, this hue indoor sensor has reached maybe like 75 lux max. So I definitely am toning the curve down to match my use case.

EDIT: If anyone has a similar situation to mine and wants to try out my values I've stuck with this so far (will update if I change again).

a: 100
b: 3.7
c: 30

My Philips Wiz lights actually turn off at anything less then 10 dimming level, so these values will have the lights turn off around 50 lux as seen in the respective graph these values produce.

1 Like

I've disabled all logging, yet I'm still seeing some logging every minute.
image

I tried turning the logging back on and then off, in case it didn't save correctly, but no luck.
Is there additional logging I need to turn off? If so, where can I find that?

For more information, this only happens during the times when the app is unpaused and the controlled lights are off.

As I've got this app configured and working as I'd like, I'd like to be able to turn off all logging so that it doesn't clog up my logs in case I need to go back and look at some other app/device's logs. :slight_smile:

Looks like this particular event is occurring because another app is messing with the devices and this app wants exclusive control.

If you go into the app code open the app and comment out line 520 by putting // at the beginning of the line it will get rid of the log entries you posted.

// log.info "dimmers are off and managed by another app, $app.label will resume when they're turned back on keepDimmersOff = $keepDimmersOff"

Be sure you have this option checked though so the app can track the state of the dimmers if you kill the logging.

image

1 Like

Thank you! That's the option I already had enabled, which I believe was causing all of this logging to occur. Commenting out that line stopped the excess logging.

This has been corrected in the latest version. Thank you for letting me know. If your instance of the app is now running properly, no need to update the code at this moment as I didn't add any other modification than making this log.info line optional.

1 Like

Everything has been working great for me. One issue I have noticed. On the latest version my bulbs dim all the way down to 0. but seems like hue bulbs at 0 have a faint light to them and they don't turn off. I have an older version running lights in another room and this one actually turns the bulbs off completely. Any ideas?

Let me look into this. I'll add an off() command when dimmed to 0 so as to compensate for this kind of hardware. I'll let you know when done.

Wait, do you mean an older version of the same app Eternal Sunshine??? If so that's weird.
I've just pushed an update, let me know if that fixes the issue.

Yes. I'm still running a version I had been running in another room right before you added the logarithmic variations. I left it while I was figuring out the new settings for another group and never got around to updating it. Updating now.

Download the Hubitat app