[RELEASE] Enhanced Weather Underground Driver

That's what we are experiencing in many parts at the moment.... levee's and controls that were once adequate are now not fit for purpose... We have land that is already sodden ground receiving even moderate rainfall that then produces potential flooding events

1 Like

Is it getting the error every time it runs, or does this happen occasionally? Are you seeing the rain history values?

Can you turn on "Enable description Text logging" and after a couple of runs PM me the Weather Underground logs.

Yes every time it polls. Rain Histories are all 'null.' PM OTW

Are you using your own PWS or another site? After reviewing the log you sent, this look as if the Station ID is not reporting rain. Can you switch to another station if you are not using your own PWS, or can you get rain values from your PWS.

I don't know enough about the PWS devices and if some don't have rain gauges. If they don't then I will need to make the rain history optional in settings.

Can you Set to 0 if you get null?

My own station. I have a rain gauge. It reports null when rain is 0.

Similar problem in this thread:

In all my testing when no rain I saw 0 reported. But I did code for the checking for null, but it must be another variation on how groovy represents null. I am using what they call "groovy truth" mentioned in your following message but does not work for these nulls.

Which PWS are you using? You can check the PWS to see is all the data is there via this URL and replacing the name with the PWS you want to check:


You can also validate that PWS is returning data directly via the API:


If these both work, then the driver should be able to pull all the data without errors:

Working through PM with user to get it to work and resolve the errors. I think we have a fix. Just waiting on @C379776 Dan to get back to me. I was able to use his station values with the modified code and it worked for me. Hopefully it will work for Dan and if confirmed all is good I will pm @dJOS you the updates.

1 Like

Sweet. :slight_smile:

Thank you dJOS and swade for developing this driver.

I’ve got v6.7.0 installed and I’m pulling in data ok but when I tried adding the following tiles I can't see the attributes: html3dayfcst & htmlRainTile. Looking a prior post there was a bug that was fixed but I’m seeing this issue. Or am I missing something?


Did you force a poll after updating and then refresh the dashboard after about 2 mins? Usually it takes a little time to appear.

Hi dJOS,

Yes, just tried that again without luck so I just deleted it all and started again and set the station ID to IMELBO809 as I saw you had used this in a previous post. I’m still not seeing the html3dayfcst & htmlRainTile attributes.

Also is the below error expected when clicking on “Poll” or “Force Poll”?

Hope this helps, It looks like after the fist poll it's not poling after that I just keep get the line 280 error.

Ok, a fix is coming.

1 Like

Working without any warnings with the patch. Nice work and thanks!

You're welcome. I think the null errors are how different PWS brands report values to WU. Fixed for now until we get a report of some other variation. :grin:

I sent the changes to @dJOS and he will get the updates submitted to HPM.

1 Like

I think I resolved your error from Line 280 with the latest release. Once @dJOS gets the updates to HPM, please try the newest release and let me know if it fixes your error.

1 Like

Hi All, v6.7.1 has been published - please test it out.

1 Like

Thank you that has fixed the null+1 on line 280 error and it's now updating every time I hit the poll button.

The only errors I'm seeing in the logs now are as follows:
errorjava.lang.NullPointerException: Cannot invoke method replace() on null object on line 566 (method pollHandler3)

errorjava.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Throwable on line 850 (method poll)

Please also note that I still can't see the following attributes: html3dayfcst & htmlRainTile

Also I've change my Station ID back to: IADELA951 (This is the Station ID I had set when getting the above errors)

Thank you again :slight_smile:

1 Like