[RELEASE] Echo Speaks V4

Also, Album Art isn't updating at all after the first song on a WHA group - but I can force it to update if I toggle debugging and "save preferences", triggering an Updated() and initialize().

[UPDATE: I've been digging into the code. It's fairly easy to understand after you stare at it long enough.

I think the problematic line is 520 of Echo Speaks Device:

if((Boolean) state.isWhaDevice) { return }

This basically makes multi-echo groups ignore updates. Commenting that out seems to cure the WHA groups not updating album/track info as they play. No obvious negative effects... (so far)]

[UPDATE2: This appears to also fix non-group track data updates after being part of a group]

@tonesto7

I'm not sure if this is related to your new release, but wasLastSpokenTo doesn't appear to be updating anymore. It keeps coming up as "null".

And yes, I'm completely upgraded. I noticed this problem after the upgrade because some of my pistons use this setting.

image

Now that the Beta is over I decided to install on my production Hubs. Something either in the new version of Hubitat or the final release the ability to duplicate actions seems to create a action that returns a internal server error when attempting to edit the duplicated action. The source action uses a "virtual button".

What version of HE firmware are you running?

If not 2.2.6, can you upgrade to 2.2.6?

You will have to try the duplication again if you upgrade

I got the same error. If I duplicate an action, I got an error when I try to access it for editing.
And since I can't acces the duplicate action, I can't delete it...
I use the latest firmware 2.2.6.130

I got almost the same when trying to duplicate Zones, I got error screen , and there is no way to edit the new Zone nor can I delete it

If any of you with the dup problem are comfortable editing a little code, please send me a private message and I can provide instructions to help test this.

Please let me know your HE firmware also.

I have a fix queued up for Tony to release on this.

1 Like

I have a fix queued up for Tony on this. Would appreciate help testing once he pushes it.

I see there is a new update this morning:

image

It worked! Thank you and @tonesto7 . :slight_smile:

1 Like

Hello. Just getting into Echo Speaks now and it seems like this will be fun.

Will there be support added to allow the Echo to whisper?

It supports all SSML features like whisper, tone, voice.

Under actions, there is a speech designer where you can build them.

Running the latest version (4.1.2.0 client, 2.7.0 server) but now seeing this in the error log...

dev:10582021-04-03 20:52:12.533errororg.codehaus.groovy.runtime.metaclass.MissingMethodExceptionNoStack: No signature of method: user_driver_tonesto7_Echo_Speaks_Device_1665.deviceNotification() is applicable for argument types: (java.lang.String) values: [Warning, someone is in the treats cupboard!] Possible solutions: removeNotification(java.lang.String) (deviceNotification)

Any ideas?

It is a bug. I have a fix queued to tony

If you want to fix in interim semd a private message to me

1 Like

Thanks @nh.schottfam... happy to wait for the next release... assuming it’s imminent...? :wink:

Any ideas on thes? The device errors are from two echos I mute every night and unmute every morning. Not sure what the app errors correspond to, except that it is odd they are exactly 3 hours apart and if you look back in the log that's a definite pattern. Here's the version info...

Screen Shot 2021-04-04 at 9.53.21 AM

a fix is into Tony to release for this.

Awesome, thank you for the quick update.

@tonesto7 @nh.schottfam

Something changed the way it speaks time. For example, in the text "Alarm set for 7:00 AM", it used to speak "seven o'clock". Now it says "seven oh oh". I'm not sure exactly when that changed but I think it's some time over the past couple of weeks. Is that something on Amazon's end or in the echo speaks software?

Download the Hubitat app