[RELEASE] Echo Speaks V4

Any ideas on thes? The device errors are from two echos I mute every night and unmute every morning. Not sure what the app errors correspond to, except that it is odd they are exactly 3 hours apart and if you look back in the log that's a definite pattern. Here's the version info...

Screen Shot 2021-04-04 at 9.53.21 AM

a fix is into Tony to release for this.

Awesome, thank you for the quick update.

@tonesto7 @nh.schottfam

Something changed the way it speaks time. For example, in the text "Alarm set for 7:00 AM", it used to speak "seven o'clock". Now it says "seven oh oh". I'm not sure exactly when that changed but I think it's some time over the past couple of weeks. Is that something on Amazon's end or in the echo speaks software?

Try checking and changing the setting "Text Transformations" to see if it changes anything.

In HE console
-> Apps -> Echo Speaks -> "Manage Logging and Metrics" -> "Disable Text Transformation"

I'm not sure that is issue, but something to try.

After that we can try some other things via private messages and log sharing.

Didn't work.

One more thing, while we're at it: the "speak text and restore" command doesn't set the volume properly anymore. This basic test fails to set the volume to 1% before speaking the text:

The best way to confirm if it's an amazon change is to create an alexa routine to speak the same text and see if it happens there.

Alexa won't let me create a routine to speak that text: it gives the error "Phrases can't contain special characters" (complaining about the colon). Does that mean it's an Echo Speaks bug?

That's an Amazon restriction

I have posted a fix for this volume issue to Tony.

We are still trying to understand your initial issue on time, and what changed and where....

Thanks. Please let me know if there's anything else you need from me for the speech issue.

I believe this was an amazon change.
(Tested with echo show "tap to alexa" -> "quick question" and entering: "simon says it is 7:00 AM" and got the same result ""seven oh oh" as posted by @dsegall)

1 Like

Interestingly, the Alexa "voice history" also shows the colon charactor (":") between numbers replaced with space

1 Like

I'm seeing something probably similar. I used to have SSML in some of my Echo speak actions like:

<audio src="soundbank://soundlibrary/sports/crowds/crowds_12"/>

that would play when my girlfriend walked in the door.

Since updating to the latest 4.1.3, Alexa now literally says "audio s. r. c. soundbank soundlibrary sports crowds crowds 12". Setting the "Disable Text Transformation" has no effect.

My hunch (that also explains Tony's time issue) is that all (or most) non-alphanumeric characters are getting stripped out somewhere they used not to be.

1 Like

Do you wrap your message in: ?

<speak>message....</speak>

This is the input for ES to understand it is SSML, and it should leave it alone. ES will strip the

 <speak>

and

 </speak>

When it sends it to Alexa and tell Alexa it contains ssml

1 Like

if you are comfortable editing a line of code, reach out to me in PM, for something to try

In the past, explicit <speak></speak> tags were not required. I had assumed perhaps that the echo speaks app had automatically added them.

When I add them explicitly, I only get silence. There's something that's at least messing up log output since the parameter values of the speak command don't show up. Here's the log output.

[app:161] Action (v4.1.3.0) | ExecuteAction Finished | ProcessTime: (266ms)
[app:161] Action (v4.1.3.0) | Sending speak Command: (

[app:158] addToQ (multi) | Command(1): [command:ssml, value:
[app:158] addToQ (multi) | srcDesc: sendDevObjCmd speak to device 158|echoSpeaks|GXXXXXXXXXXXXX
[app:158] addToQ (multi) | callback: finishSendSpeakZ
[app:158] addToQ (multi) | device: 158|echoSpeaks|GXXXXXXXXXXXXX
[app:158] addToQ (multi) | time: 1617907146456
[app:158] addToQ (multi) | cmdMap: [cmdDt:1617907146456, cmdDesc:SpeakCommand, message:&speak&&audio src="soundbank://soundlibrary/voices/chorus/chorus_12"/&&/speak&, msgLen:78, oldVolume:65, newVolume:80]

Anyone running into issues with it showing that guard is not available anymore??

ok this is fixed in latest updates to Tony

Can you give more details on the issue?

Download the Hubitat app