[RELEASE] Echo Speaks V4

This is happening for me as well.

Whoa mine sounds like a squeeky robot this morning.

I'm seeing this every 10 minutes also.

just checked, i have it also. every 30 minutes on the dot.

I am now seeing this every 6 minutes. Everything seems to be working fine, just the errors in the log:

This has been an issue for a few weeks. If you want to stop them see this post:

How do you "rem out" those lines of code? I tried simply adding "//" by keying in the forward slashes and I get an the error below:

expecting '}', found 'else' @ line 2788, column 11

Here's what I did... ("Echo Speaks" Apps Code)

1 Like

Ensure you are doing all five lines including the close bracket on line 2787.

Is anyone else getting a weird robotic squeek of a voice? is this from the error? Its freaky, i have disabled all voice output because of it.

Mine went off today for my Garage being open too long, sounded normal to me.

I am stuck in the dreaded authentication good but not logged in loop. Used correct callback url but everything looks good, but when i go back into echo speaks app in hubitat it says no longer longed into amazon. Any help is greatly appreciated. Also, disclaimer, Im not super technical Im just somewhat decent at following directions and working through things lol. Im not a coder, with that being said im down for any suggestions to help me out.

Hey man Im having this same issue, running on RPI 4 any ideas what I should do to fix this?

Did you follow all of the info here? [GUIDE] Echo Speaks Server on Docker (or without)

1 Like

You can just rem out line 2800 with //.

Thank you jkudave. Some of the posts showed "remming out" several lines. Your simple solution of adding "//" to line 2800 worked for me. Now my logs don't show the error.
Thanks for taking the time and providing a simple solution!!!

1 Like

Done. Thank you!!

I can't for the life of me figure out how to create a basic action without triggers?

For example, I want to have a virtual device for which when i activated will either say "alexa, turn on XYZ" or send a command "alexa, turn on XYZ"

Any rule has to have a trigger OR it's actions can be run from another rule.

1 Like

In my case I am hoping to create virtual device that will send commands to alexa. The trigger would be a "press". So for example, on a dashbaord I would have a button for "vacuum clean kitchen" or "vaccum clean entire apartment". I am not sure how to create that using Echo Speaks and virtual device