[RELEASE] Echo Speaks v3 + Actions

Had a couple doing that before I unplugged them for about 30 seconds and then plugged them back in. Wondering if Amazon pushed out an update recently...

In my case, it isn't something recent... It does that rather often unfortunately...

Looking for some help.
I did this a while back on ST, so I already had a Heroku account.

If you look at my screenshot. According to the documentation, I should be seeing a screen like the one on the left. But it brings up the screen on the right after clicking on Manage app.

Not sure what to do or try.
I also tried deleting the Echo Speaks app. But I get the same screenshot..

Click open app at the top. From the ss on right.



A while back there was talk of an "Echo Speaks Lite" version specifically for Hubitat.
With the demise of ES in ST coming closer and closer (if I understand correct), do you have anything in the works?



You could always check out this:

(Stupid ?) question: is there a way to access functionality other than volume control in the dashboard? If so, what are the tile templates to use?.

Does anyone know how to get rid of this error?
It has just began the last day or so.

I don't care about Audible, I was simply trying things out on the Alexa app.

Is there a way to clear queue or disable Audible?


I just pushed up a new version of the app and driver which adds a 20-second timeout to all HTTP requests.
Hopefully, this will curb these runaway threads that are crashing the hub.


Just installed the app and it went quite well. Thank you! Is there a way to have the Alexa app that is running on a Samsung Galaxy Tablet to operate like an Echo dot in making announcements from TTS?

Just updated but there seems to be a issue with the main app saying I have the wrong Device version.


And I did press the done button a few times and it didn't clear this notice.

Did you update the device driver?

Of course. The images show I have.

1 Like

Seeing the same

I can't quite remember(standard these days) but I think this is the same issue that popped up a while back. See the post below, this was an issue a few of us had. If it's the same this corrected the problem.

Not the same issue.

1 Like

I had the same issue, I wish I could tell you how I fixed it, but I am really not sure what did to fixed it. Last thing I did before it started working was went into the service management section and manually refreshed the cookies and then clicked next.

Can anyone help me please? I'm trying to get Echo Speaks and I've set up the app with Heroku but I can't log in and every time I click on the setup from Hubitat I get this screen:

If I open the app from within Heroku I get a login page, but when I try to log in I get the screen shown in the first screen shot again.

Does anyone know what I'm doing wrong? I feel like I must be doing something really stupid.

Thank you

Yes. You haven't copied the code in step 2 of the server install and put into into the first field/ app name in the next step, as per the instructions.

I can't believe it was so simple, thank you.

I saw that it said to copy it and paste it when prompted but I never found anywhere to paste it :slight_smile: