Release 2.1.7 Hampton Bay Driver Set Level Still Not Right

Almost!

Settings for 25%, 75%, and 100% work just fine. 50% gives a warning (see log below) and tries to set to "medium low". But, the fan doesn't change speed.

One thing I noticed in the log warning message, I noticed the hyphen was missing from "medium low" when setting the level to 50%. However, the hyphen is present when setting the fan speed to "medium-low" (last command sent in the log).

1 Like

I’ve observed the same behavior. Additionally, when set to high (100), the current state for level is “null”.

@mike.maxwell

1 Like

Now why didn't I think of that? LOL!

1 Like

I'm not seeing this using setLevel with the component fan device

Hmmmm? I wonder if that is happening when using "Set Speed" to High? I didn't see that when using "Set Level" per my log above... I'll check it tonight when i get home....

I see the same behavior using "Set Level" or "Set Speed". The log says:

dev:5172019-12-03 05:27:10.981 pm infoGameRoomFanController fan speed was set to high

But the Level state shows this:

Interestingly, if I refresh the page, the Current State for Level goes back to the previous value (but Speed remains correct).

Let me know if there is additional debug info I can provide.

1 Like

@jerias.mitchell @matthewschultz92
I remember @mike.maxwell mentioning somewhere that you would need to remove and readd the component devices for it to work with the updated driver. Have either of you "refreshed" your component devices for the fan controller?

Hadn't noticed previously but I have the same issue with both of mine. Curious also why the driver has 5 different speeds? Are there some that have this many? Mine has only 4 actual speeds plus off and auto.

Driver shows the following when set to the different speeds
low = level : 25, speed: low
medium low = level: 50 speed: medium low
medium = level: 75 speed: medium
medium high = level: null speed: high
high = level: null speed: high

@stephack I did go through mine and hit the Save Device button but didn't make any difference.

I'll let Mike respond with a definitive answer, but I believe you would need to remove both component devices and readd then. This of course will also remove them from any automations, so you would need to readd them to your apps as well.

1 Like

I had recreated the component devices previously, however, I just removed then recreated them again for one of my fans as a test. Unfortunately, the 100/high/null behavior still exists for me.

Just went back to mine and removed and recreated them with no changes to anything.

OK, found and fixed the two noted issues (level null for medium-high and high), this will be in a forthcoming hot fox release.

There is no need to remove or reinstall the child components.

3 Likes

Just did a quick test after updating the hot fix. Both issues appear to be resolved now. Thanks @mike.maxwell !

2 Likes

Yes, thanks @mike.maxwell, it's working correctly for me as well now. I'm curious about the "medium-high" setting though. Are there some of these controllers that have 5 speeds? Mine only has 4 and medium-high and high both do the same thing. They set the level to 100 and speed shows "high" if either setting is selected. It's like I have 2 selections for high but with different names.

1 Like

@mike.maxwell Thank you! Much appreciated!

Does this update allow for control of the fan speed using the amazon echo skill? I have been successful in getting the echo skill to control my Hampton Bay light intensity, bit not the fan. Any hints on how to enable that would be appreciated.

Yes, control via Alexa (and homebridge/makerapi) has been restored for me. Note that you need to specify the fan speed as a percentage like a light. I.E. “Alexa, set the living room fan to 50.”

Perhaps I have this configured incorrectly then. I have my Hampton Bay fan device in HE using the Hampton Bay zigbee controller (named" bedroom fan" as device label). In the amazon echo skill I have "bedroom fan" enabled as a selected device. In my Alexa app this is discovered as a light. If I issue a command in alexa app using routines I have choices to control the power or power level. When I issue a voice command to set the fan to 50 it sets the light illumination to 50%. I obviously don't quite have the configuration correct.

Do you have it split into the two component devices? I don't think the Echo skill will control the fan with the parent device since the "setLevel" command there is for the light.