Registration issues

Got a new Hubitat. Scanned the QR code in the box. It failed to find my hubitat, so I went to Advanced, entered in my IP address range and it located it.

The first thing it did was ask if I want to update. I clicked yes -- it gave me an error, so I skipped it.

Went through the rest of initial setup (zip code, created user account). It sent a verification token to my email. When I entered in the token I got an error (I forget what exactly). I double checked, and the code was entered in correctly. So I entered it again, and it told me that the code was already verified.

So, I tried to login, but it said "invalid ID token". If I click "Forgot password" it says the same thing.

If I try to go through the registration process again, I get nowhere.

Out of curiosity, I tried to login to the mobile app. This worked! Now I can log into the website too. So, I go to hubitat.local in my web browser and click "Register Hub". It asks me to setup a new account, but I already have one. So I click "Login" and login successfully. But it just redirects me back to the home page.

Now, if I click Register Hub and then click Continue, it just redirects me back to the home page. If I click on my account, it says that I have no devices registered.

If I go to Settings -> Check for Updates it just spins forever.

So, any ideas on how to proceed and get this thing registered and updated?

Can you try rebooting the hub and clicking Register again? If that doesn't work, please PM me your hub's id, I can at least confirm whether it is online and registered.

1 Like

Rebooted. I still see the "Register hub" button, but when I go to my Account it shows that a hub is registered. Edit: The Register Hub button finally disappeared, and it's letting me do a software update now.

Can you tell me exactly what happened?

The new user experience is really poor. So many errors and things not working. Is this a one-time thing, or is this going to continue to be my experience with the hub?

This sounds like the hub didn't get the registration reply. If you PM me the hub id, I can look through some engineering logs, that will hopefully provide a clue.

Will do, thanks.

Is it possible that as a new user I'm not allowed to send direct messages? I'm not seeing the option anywhere. Can you send me a message, then I'll respond?

1 Like

Please join the Hub Owners group, then you'll be able to send private messages.

https://community.hubitat.com/g/owners

3 Likes

Looks like hub time jumped several years into the future, which affected all SSL based communication. No further clues as to how it happened, I'll have to dig into that.

6 Likes

Huh?

Obviously the hub was hit with 1.21 gigaWatts of electric power.

4 Likes

The cloud? Where we’re going, we don’t need the cloud.

3 Likes

Download the Hubitat app