Register Sengled bulbs with C7, then nothing

Trying to retire my ST hub [Aeotec v3] - but have these 3 Sengled bulbs that I can't get to work with HE.

Background: Transitioned to Hubitat because I could not give up time/effort put into WebCORE. Finally found time over Thanksgiving weekend to move the stragglers over to Hubitat.

BUT - have these 3 outdoor light fixtures on separate switches, that need RGBW lamp capability. [My own fault, :smile: as we use these lights now during Christmas, Halloween, etc.]

I can remove a Sengled bulb from the ST hub, reset to factory [AFAIK], poll for new Zigbee device in HE, where it gets recognized, and added to my desired "Outdoor" room.

And there the &^%$#@! thing sits - no response to commands from inside Device area in HE Tools.
Based on other threads, changed the driver to Generic Zigbee RBGW, but still no joy.
Move bulb back to ST as I need these to work automatically, for perimeter security lighting.

Final bit of info:
2 are standard Edison socket, and ST device Information indicate firmware version 26.
3rd one is a candelabra base, showing firmware version 16.
[ST says all three devices' firmware is up to date].

I need to get these bulbs registered on the HE hub AND have them work...

What am I missing and/or doing wrong?


Use the Advanced Zigbee RBGW Bulb driver and save it. After that click the configure button. The bulb should cycle through some colors and then turn blue.

K, I'll try that... Back in a bit

OMG... I need a drink... It's Alive, ALIVE!!!!

I didn't get the color sequencing like you describe at this point [actually got that when I reset the bulb back to factory].

However, my sequence was:

  1. After doing the factory reset, got HE to scan and "see" the 'new' Zigbee device, which ended up being identified as Sengled Element Color Plus...
  2. changed driver as you suggested and saved. Turned bulb on via switch.
  3. Tapped Configure, then tried to turn off... &^%$#@!
  4. for S&G's, turned switch off, counted to 5, re-applied power to bulb, bulb lights.
  5. Tried Configure again, and then OFF
  • and then fell over as the misbegotten $#@! worked...

My best guess is that in spite of moving my Wireless Access Points to channels away from the Zigbee Channel 23 that I have that mesh set to, it takes a while [in my case] for the handshaking to completely settle - even with a few repeaters in the mix.

Bottom line, I was grudgingly looking at having to spend more $$$ to replace working bulbs.

I thank you for freeing up funds for Cyber Monday!!

1 Like