Rebooting hub triggers thermostat scheduler to override current settings

When I reboot my HE, the Thermostat Scheduler wakes up and sets the heat, fan, and mode to whatever values were set at the last timing point in the schedule, no matter how long ago that was, undoing the current settings:

Thermostat Fan Mode auto from Time Schedule
Heating Setpoint 20.0 from Time Schedule
Thermostat Mode emergency heat from Time Schedule

I don't want that. How do I turn it off? When I reboot the HE, I don't want Thermostat Scheduler to mess with my thermostat until the next timing point arrives.

If this isn't possible, does HE have events for shutdown and reboot that I can trigger on to write a rule to save the current thermostat settings and then restore them shortly after booting (to over-ride what Thermostat Scheduler is doing)?
If this isn't possible, I'll abandon Thermostat Scheduler and just write rules to set the thermostat myself.

Tagging @bravenel.

There were user requests for Thermostat Scheduler to come up at system start, put itself into the correct time period, and to set the thermostats accordingly. So that was added to the app. This is a great example of 'your use case isn't my use case'.

I will figure out a way for this to be optional. And that option will be in the next release. To avoid surprises for those counting on this functionality, the option defaults to on, so you'll need to open Thermostat Scheduler and change it to off. Thermostat Scheduler will continue to set itself to the correct time period upon hub reboot, but won't adjust the thermostats without the option set.


That would be great. And I hope the option is visible in RuleMachine so that it can be turned on and off via programming. The current behaviour (set thermostat according to the previous timed setting) is a good default, especially after a power loss of undetermined duration. The only time I'd want to over-ride it would be on a manual hub reboot (e.g. after an update). So I also hope I can write rules to trap a request for an update or hub reboot and turn on this option, then turn it off after the reboot is complete (and go back to the current default setting).

None of this is possible now, nor likely to be. Nor will the option in Thermostat Scheduler be settable by RM. This is all feature creep...

Okay, then never mind adding the option to the scheduler. I'll write my own scheduler.

In the websocket log I see a JSON record for the update event:

{"source":"HUB","name":"update","displayName" : "null", "value" : "", "type" : "null", "unit":"null","deviceId":0,"hubId":1,"installedAppId":0,"descriptionText" : "Updated with build:"}

I presume that RM has no access to this event? I don't see any events related to a manual reboot.

What about room lighting or mode manager? I totally get the concern for feature creep. In my case I prefer to live with restarts overriding manual adjustments.

What about them?

There were user problems arising from hubs coming on after power outages, and things that should have happened but didn't, and numerous requests for this to be fixed. So modes get set per the schedule in Mode Manager, and in the case of Room Lights lights that should have been activated or adjusted, that happens (if those options have been selected, activate/adjust on time period change).

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.