Really struggling with the transition from Vera

The number of headaches that originated from trying to run Vera over the years made it impossible to stick with especially when the unit count got over 100 devices (I am closer to 130 presently).

One I learned about Hubitat, I read and while trying to follow the proper protocol and instruction I have:

  • Centrally located the Hubitat in the house. Presently living above my basement door on a small shelf I built directly inside the door so it is not visible and is ≈8' off of the first floor in altitude.
  • Did my best to replace all the non supported devices with Zooz, Dome, and Fibaro devices that are supported.
  • Added the devices, and a couple signal boosters around the house so that the newly added devices could be included "where they will ultimately live".
  • Performed a number of Z-Wave Repairs in hopes that things eventually get their act together.
  • Disabled the ZigBee radio in hopes that there is more power available for the Zwave radio.

Here are the results and frustrations listed that I need help with:

  • Associations:
    First, the inability to create direct associations (and I only have 4 to do), is frustrating. One is a Fibaro eyeball to a switch in a powder room. If I use the motion app (needing the on delay before leaving people in the dark), there is a huge delay before the light goes on.
    The other three are Dome Pro door sensors that need to turn on closet and pantry lights. Did these in Rule Machine and I am lucky if the lights turn on reliably, and even more lucky if we don't have to get up and turn the lights off manually.
    Incidentally, triggering the switches from their interface is near instantaneous.
    I also tried the Inovelli association app (perfect execution of the implementation but only works with their devices)

  • Groups: I have a Fibaro button that is set in rule machine to be one press turns our inside Christmas light GROUP on, and two presses off. It takes sometimes up to a minute from the time the first light turns on or off, until the last one "may" comply. I don't know if the group itself seems to be the culprit as activating it manually eludes me to test - but the delay makes the timing of things a bit erratic.
    I do know that the plug-in modules are the least reliable - even if they turn on fine, shutting off is hit or miss.
    On the Vera, this was a near-simultaneous event.

  • Including:
    I have multiple switch boxes with multiple switches in them. I have been able to include one or more within a given box, but there seems in more than one of my multi-switch instances, that the remaining switch will exclude fine, but never include. It can't possibly be a signal thing, then I though interference, then I realize that no issues at all with the Vera - same switches. Why would two neighbors ⅜" away include and the monkey in the middle not?

  • Non Zwave Plus devices:
    I have dozens of outlets around the house that are not ZW+ and I cannot get them to join as even generic something-or-others. I need nothing fancy just on and off, I know that signal is sufficient because they are in the crossfire of included devices and signal boosters, yet they are not acknowledged at all.
    Is there no way to utilize all these outlets? I hate the idea of cluttering everything up with plug in modules.

Overall, I like a lot of things with the Hubitat, namely speed of enrollment. I am very frustrated that it requires so much baby sitting to make sure it is doing its job.

I have also taken advantage of the latest Christmas sale and ordered another in case someone knows how to perhaps have them join forces to be more powerful and reliable?

Sorry for the long post but I am running out of ideas.

1 Like

Sounds like your network isn't working well. Your bullet with association and things being flaky, maybe it's rules or maybe it's commands not reaching the device? I think there's a few things I've done to make my life easier with ZWave:

  1. Always have logs open while including devices and watch what's going on in logs vs the discovery screen. After including 50 some devices I don't trust the UI at all and how it count downs.
  2. Once you start include/exclude wait the entire time (or logs indicate it stopped doing) before issuing another command.
  3. Exclude a device, then include it. If the exclude is successful (either excluded a named device, or a unknown device) then it'll include almost instantly.

I have a good number of powered devices, GE switches, Zooz devices, etc and I've had a very reliable system assuming it isn't being spammed with messages. I had to pull one zwave device that produced 100's of level reports when turned on and it ruined the network.

So last tip, look in the logs and see what's going on. :slight_smile: Good luck!


I have a mixture of ZW and ZW+ devices. I've not had any issue joining either....... well there have been a few stubborn ones.

I tip I read while I was moving from Vvera was to only pair 10 devices at a time. Allow time for the Z-Wave mesh to be created. I was told this could take a day.

1 Like

Thanks for the ideas @asj and @JohnRob.

I tried opening the log on my iPad and doing the exclude/ include on the phone so I could monitor the log. I still get near instantaneous excludes (but nothing in the log stating that the exclude has stopped), so i tried to just wait out the 30 seconds before doing a reset and include (as the little instruction states at the top of the discover page), no joy. Tried without the factory reset - no joy.

I don't see other devices or "chatter" in the logs - is there a way to see if there is potentially a rogue device messing up the works?

Is there any advantage to first going around and excluding all the remaining devices that were once on Vera? Any possibility that they are trying to find the mothership and wreaking havoc on the new controller?

And, yes, I have done the 1-3 day "soak" before adding more. I haven't been able to do 10 in a row except for maybe day one (which is now a coupe weeks ago).


If your Vera hub is still powered up, you might try powering it off while you are pairing devices with the Hubitat hub. Then go through the exclude in the HE UI and then include.

Thanks @zarthan, they are all powered off. Just didn't know if the actual devices were somehow still meshed and interfering.

I had a couple of folks that were heavily invested with Vera and they are also moving from that platform due to the support falling off. When you do have multiple Z-wave networks it's best to work in baby steps. Remove a few devices from the original network with the Z-wave exclude function and then disable exclude mode and wait 5 minutes for that Z-wave network to settle down. Then add those devices to the new network and wait again for the Z-Wave network to settle down.

What I found is that if ether of the hubs were in exclude mode you can do a forced exclude from the devices if something went wrong but always wait a short while before doing includes. I never advise to do the "big bang" due to the way the Z-Wave mesh establishes itself.

I’ve stopped using iPhone or iPad for pairing new devices and now ONLY ever use my Windows laptop.
Dunno why but Ive just had much better success using the windows laptop.

I've also had issues in the past while pairing zwave devices. I suggest after every few devices:

  1. Shutdown for at least a minute
  2. Zwave repair
  3. Reboot

New issue and follow-up:

I was trying to add a new device and it appeared to be recognized - yay!
However, it stayed stuck at initializing device and I let it go for 10 minutes - still stuck on that screen, so I rebooted in case something was really stuck - when I went to add a completely different device, not only did the new device (initializing device), screen come up, but the one that was stuck prior to the reboot as well (saying initializing).

I have no idea what is going on and how to manage these things. Is there a command to clear them, or an app?

As far as follow-ups:

  1. Is there a way (a rebuild didn't help, nor a reboot), so I don't know at what level these commands are stuck and how to clear them out?
  2. Is my location an issue? I presently have the device sitting on a small shelf above our basement door as you go down the steps (so it is overhead on the first floor), and within about 18" on each side of it to the nearest wall, 3" from the wall behind it, 24" from the ceiling, and 4' from the wall in front of it. Am I hamstringing it somehow?
  3. Any problems once the holidays are over, to reset it, factory reset every device in the house and start again? I figure I can factory reset everything before trying to remove and re-add everything which may be easier - but at this point I have no clue.
  4. Are you guys bringing the battery operated devices to the hub to enroll, or are you able to enroll them at their final location?

Thanks, and I did get the second unit but have not unboxed it. If there is any way to couple them and increase power and reliability - please advise.

Happy New Year,

Of course your experience maybe different but I just added a Fibaro Single Switch to my Hub by Pairing the FSS right next to the HE Hub and then installing in its final destination. There is an Aeotec Repeater between this final destination and the HE hub which I’m guessing the FSS is now using but the FSS would not Pair in place.

If you can't pair them in place then there is usually something wrong, so always best to try and get it working in place otherwise your likely to have problems.

The only devices that you have to pair close to the hub are Z-wave door locks and Garage door openers. These are always joined "secure" and therefore must be close to the Hub when pairing as the secure pairing process cannot happen through a repeater.

On that subject though...what is you setting for Secure Z-wave? Di you change it from the default of all devices to only locks/openers? That will greatly affect your Z-wave performance and pairing.


If that is set to "All Secure Z-wave" then you will definitely have trouble pairing devices to the hub. If you are coming from Vera, I would suspect that all of your devices are either Z-wave or Z-wave plus, correct? If any are newer, then they will support secure inclusion and would try to pair securely if this setting was incorrect.

Thanks for that. I have both of those drop-downs as Enabled. I didn't really understand the setting, so I had left them. Since I won't be adding locks or openers in the near future (the two I have are the only things controlled by my Honeywell Alarm panel with Zwave), and I don't want to lose the functionality of closing the garage door when the alarm is armed from the bedroom.

I had to read your post and the documentation a few times but I think I get it.

Setting the Secure Join the way you outlined it says that only doors and garage doors are required to join securely. Everything else can come as they are?

I had it the other way around - it is not a clearly defined setting in my opinion - at least the documentation could be a little clearer.

I will experiment later today.
Thanks - this may be the news I have been waiting for!

Setting it like that will force them to join securely but will ensure everything else doesn't basically.

The issue is z-wave was never built from the ground up to be secure like zigbee is so z-wave secure is essentially a add on. Due to this there is a lot of overhead once joining securely and this massively bogs down your network, so you only want to join securely the things that need to be secure.

Having it set to join everything securely will mean that every device will have to pair close to the hub. It also means that unless that secure join is successful, the device may pair to the hub but fail to function, which sounds a lot like your problem. The recommendation is that this setting should be for Lock/Garage Doors only.

Thank you @BorrisTheCat and @Ryan780,

That makes sense but now makes me wonder if the flakey things are a result of the wrong setting and if they now need to be excluded and re-added?

The reason I ask is after changing the setting and going to one of the more stubborn devices, I had the same result (not joining), and this is one of the switches of three in the same gang box where the two others joined.

Thanks everyone. I'm sure I'll get there and appreciate all the help and patience.

If they attempted to join securely, then yes. The only way to correct the problem is to exclude them and re-pair them to the hub. Unfortunately that means that any automations you built with these devices will have to be rebuilt once they are re-added.

Sorry that no one else thought to suggest this to you sooner. These are the classic systems for a z-wave mesh issue of this kind. The good part is that if this is the cause, you'll know right away when you begin rejoining the devices to the hub after excluding them. And remember, start with the devices closest to your hub and move outward. And start with repeaters/mains powered devices first. And once you have joined 20 or so devices, give the network a bit of a break before joining more. There are more suggestions/details located here:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.