(re) registration ? after removing from list of registered hubs

Got my hub completely configured. Final step was to set a static IP address. All went well and I could access the hub using the new ip address from the browser. Then went to my,hubitat.com and the hub showed up with it's old IP Address.

I'm using the latest Edge on Windows 11. Tried advanced discovery. Discover by mDNS did not find it. Discover by MAC found it with the old IP Address, and ip address range scan could not find it. Decided to deregister the hub (bad move?) and try again. Same results, could only find it via Mac adderss and that always showed the old IP Address, even after rebooting the hub and the PC

Next tried Firefox. mDNS would find it with the address hubitat/local. IP address would find it with correct static address. However now I can access it locally but I've lost the cloud registration. I cannot get to the registration card to register the hub. Any ideas ?

OK, fixed it. Clue was the "Cloud connection unavailable" message. Needed to fix the DNS Server entries after switching to static address (The default ones did not work in my case). After changing it to my gateway ip address and google (8.8.8.8) all is good and I was able to re-register the hub

1 Like

Yeah, sometimes when setting to static on the hub itself the dns doesn't take the first time. Though it's more recommended to set a reservation on your router itself for iot devices because you can see what's what in one place and if you want to make global changes (like switching from 8.8.8.8 to 1.1.1.1 it's much easier.

Download the Hubitat app