Question on HPM updates (related to HPM 1.8.5 transition)

I wanted something as a developer and as a user also. Sometimes you don't know you need it until its there. I have a feeling it will get used more often than we think.


Used vs Need. I agree it will get clicked a number of times.. "Ohhh, shiny new button, let's see what it does." "? Doesn't do anything, let me try it again." On the 3rd or 4th attempt, they'll notice the list to un-match is smaller... and panic. Never once will the words "Follow with a Match Up" be read. :smiley: (Where's my cynical emoji?)


I just Un-Matched three packages that I didn't want to ever update, and having them be matched in HPM made for extra notifications and the risk of accidentally updating them when using HPM otherwise.

The alternative was reconfiguring a bunch of stuff after uninstalling from HPM and manually reinstalling. As a user, un-match is much better.

As a dev, the ability to relocate repos or use it for maintaining different versions is going to be really useful.


I ran HPM updates and got the HPM 1.8.6 version installed BUT now HPM View Apps & Drivers shows both 1.8.4 and 1.8.6 installed! I ran Update, Uninstall, Repair (on both) and rebooted the Hub but both HPM versions are shown as installed in View Apps & Drivers. Apps Code only shows one set of code.

How can I fix this?

Try the Unmatch option with the 1.8.4 version (under Settings)

It's purely cosmetic.

Follow the advice and: Use Un-Match and pick both HPM when offered. Click Done/Next all the way out. Fixed. For HPM, no Match Up is needed.

1 Like

Getting this error.

app:14442022-06-21 10:36:32.972 pm errorjava.lang.NullPointerException: Cannot get property 'repositories' on null object on line 3923 (method prefSettings)

app:14442022-06-21 10:36:32.952 pm debugRefreshing repository list

app:14442022-06-21 10:36:32.950 pm debugConverted update mode to Never

app:14442022-06-21 10:36:32.944 pm debugMigrating auto updater mode

app:14442022-06-21 10:36:32.941 pm debugAdding GitHub and PayPal URLs to manifests...

app:14442022-06-21 10:36:32.938 pm errorError downloading Temporary failure in name resolution

app:14442022-06-21 10:36:12.896 pm debugStoring repository listing in state

Can’t even get into HPM to repair. Deleted HPM (was 1.8.3) and reinstalled (1.8.6).

Looks like your DNS server is not resolving which might explain the plethora of errors.

Thx, makes sense. Messing around with my Pihole/iot vlan over the weekend. Confirmed with network tests in the HE.

Cursing heard when all lights went on this morning.

Same here. RIP HPM.

The "Repair" option simply freezes at "Repairing Package Your changes are currently in progress...please wait" Will try vmsman's fix and see if that works

What are you talking about?

1 Like

Like some others, I couldn't get it to update and it seemed Hubitat Package Manager was broken, hence the joke "Rest in peace, Hubitat Package Manager".

1 Like

I dunno, just tried it on my C7 - said there were updates then showed "null" - I checked it anyway and it changed to Zooz Advanced Drivers, updated fine.. not dead for me yet.


As mentioned in the other topic, Hubitat has duplicated the display (null) issue and will supply a fix. For Update, there's a workaround: click to close the dropdown and then click again to open it.. which then displays correctly.

Less desirable, reverting to works.
More desirable is that works. That release fixes the display issue.


Just checking the checkbox next to "null" works too - once you do that the real entry shows in the list - at least it did for me. Easy Peasy - glad Hubitat folks are fixing though as it seems to be causing some confusion.

In terms of it being broken barring any DNS/network troubles - uninstalling and removing the apps code then reinstalling from scratch would seem like that should do the trick. I've done this a couple of times earlier when I was messing around. Also the "Un-Match" feature is very useful as well.

Thanks for working on this to keep it current - it's a really great community app.. :+1: :+1:


If anyone is having the DNS problems check post: [RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity - #211 by gopher.ny

I have observed issues with from the hub in multiple threads so that could be why some people are getting errors like this Temporary failure in name resolution



The internal ping method ( was introduced with, and I think it was around while I was chasing down a change with that method, that I noticed the ping endpoint (the one used by the network test page) wouldn't return but the internal method would.


Does this mean anything to anybody? I ran 'HPM Updates' today - Hub Info - and it sat and spun for about 5 minutes and never ended. I had to reboot my hub (well- I rebooted... had to? nah).

First time installing/using HPM...

I was having an issue with the ECHO SPEAKS app, that it wasn't working on one of my new Echo devices. I was told in another thread to get HPM and ensure that I was running the latest version.

After installing HPM, I updated several apps, but when it came to ECHO SPEAKS, I got an error message:

Error Occurred During Installation

An error occurred while installing the package: Failed to upgrade app Please notify the package developer.. Be sure the package is not in use with devices.

For that last line, "be sure the package is not in use with devices", does that mean I need to break some of my rules and take out that part of the rule? Is there an easy way to do this without needing to edit my rules that use the ECHO SPEAKS function?