Pushover with HSM

I read most of the threads on Pushover and HSM but I could not find a reference to my question. When you use Pushover instead of SMS do you remove the phone numbers if you have Pushover selected as the notification device? thanks

If you don't want an SMS text and just want pushover notification then leave off the phone number, you can get both if you want by putting in both

@Terk Great, Thanks. I assume each phone has to have a separate Pushover account or is there a way to add a second number to the existing account?

Depends on how you want to manage them, if you want to be able to send some pushover messages to one and not the other and some to both then you would need a separate account. However if you don't mind them both getting all pushover notices than you can just add the second phone under the same pushover account.

@Terk Ok, thanks. I will have to see whether the WAF factor is affected.

You do NOT need separate Pushover Accounts. Each device that you install Pushover on, will appear in the list of devices you can select from for each Pushover Device in Hubitat.

Just log into Pushover on each device with the same credentials, and name each device appropriately. We have 2 iPhones and 2 iPads all using the same account.

You can then have 1 Pushover Device in Hubitat to sends notifications all ALL DEVICES. And Additional Pushover Devices in Hubitat for each individual Device, if desired. This makes it easy to target all or individual pushover client devices.


@ogiewon Thanks very much for the explanation. You answered my next question. This has a lot of potential.

I didn't realize I could make more than one virtual pushover device and choose the devices in that account. There is a bug in that your supposed to leave it blank for all but if you accidently go in there to look at the options you cannot get it to go back to click to set (blank) at least not on my iPhone.

Please report the Pushover device selection issue to support@hubitat.com. I believe I have seen the same behavior. Should be a simple fix for @mike.maxwell or @chuck.schwer.

I'm not following here.. can you show a screenshot of the issue? are you talking about pushover driver or HSM?

I believe this is the issue... Once you select a Pushover Device from the drop down list, there is no way to set it back to a blank, which is what the driver is looking for to know to send to all devices.

Thanks! I put in an issue to get that fixed.

The driver, Now I can unselect my device, when you first setup the device it acts like a drop down and would let me unselect an option even after saving, but after you go back to the main devices page and come back into pushover driver it becomes three dots and you can unselect.