[Project Help] Hive Active Heating Driver

I wonder if it’s part of the other drivers. There are various others in the smart things forum that are for light bulbs, plugs etc..

I’d personally say, leave it and sit back and relax. Thank you so much. Genuinely wish I could do it myself, I don’t have the time to learn coding tho

Looking at the code for the parent there has to be another child app, not a device. Since I don't see another child app I'm going to call it good here.

If you update to the latest version of the parent app I removed my warn logging and I allowed the link from automations to link back to itself rather than crash.

If you guys find something that isn't working besides automations give me a shout.

Also, if you feel like it's stable and worthwhile please report back and me or somebody (even you guys) could add it to the wiki of community supported devices. Maybe I'll even do a release post if I'm not feeling REALLY lazy.


Plugged the ST hub back in and fired up the app and went through automations section.

I've attached the screen shots below, hopefully it helps, if you need more i've left it plugged in for the mo.


@mike.maxwell or somebody else from Hubitat or a very wise community member, I have a question.

This SmartThings app is both the child and the parent. There is a link that is dynamic based on whether or not it is acting as child or parent. In Hubitat, however, it appears that instead of creating another instance of itself as the child it just loops back to itself (the parent and only instance).

So, in hubitat is an app allowed to create instances of itself (same app name and namespace) as a child or does it have to create a different name and namespace as a child?

Will defo shout if i find something that doesn't work and its definitely worth a release post!

I've already switched all my heating automations from the ST hub to HE using this app & driver, so i'll get a good test of it over the next week or so and report back.

Thanks again for getting this working.

Yeah, we don't support that shortcut, it works in st, though they don't approve of it either...

Shoot... so much for the quick refactor. Okay. Thanks, Mike.

Guys, how bad do you want that functionality? I can pull the code out into a separate child app to get it to work or we can ignore it and leave it broken.

I'll personally use rule machine

+1 me to, personally i think you can just remove it.

1 Like

I hid it but left it in the code just in case some day we need it. If you download the latest version of the app the link to automations is hidden.

1 Like

Thanks again, is it easy to hide other files. I only want heat and not cooling for example, so I just comment them out or will it break it

Send me a screenshot of what you want to hide. Maybe I can parameterize it for you.

It doesn't look like it's going to be possible. Some of the Hubitat capabilities for thermostats already have the cooling commands built into them.


If I comment out the thermostat capability it takes more than just cooling with it. It takes heat() as well. The same is true for ThermostatMode. It takes off() with it even.

So, you kind of just have to live with it I think.


Just wanted to let you know this has been working perfectly, keeps up with the wife messing about on the hive app or thermostat.

not one hiccup or glitch so far.

Thanks again.

1 Like

looks like you've cracked something I have been after for a while. My heating is still on ST and want to move it to Hubitat.

I have managed to add the driver but the app is giving the error "Metadata Error: Parent App 'alyc100:Hive (Connect)' not found on line 64"

Have you used both the app and driver from github ?

1 Like

Did that happen on save? What version of HE are you on? Maybe an update made it so listing the app as a parent or child of itself doesn't work. Does it work now?

I just tried again and it failed with the same error code.
My hubitat version is

Hello @codahq

I just tried to save the app code as well and had the same error.

I’m in the latest version of HE

I’m very new to all this, do you have any suggestions in how to get it to work?