Programmed Hubitat Hub Apps not accessible after local area network upgrade

Last month I successfully completed a Z-Wave+ system integration of 30+ devices using the Hubitat C-8 Hub. I recently upgraded my local area network (new LAN hardware /SSID). I still have access to the impressive Hubitat Hub local development software, "Included" Devices, Setup Menu options, and the hub is correctly executing programmed Apps. However, since the LAN upgrade, I noticed there isn't access to my programmed Apps/Rules. To be safe, I usually created a new Local Backup every few days. I just purchased the Hubitat Protect and Remote Admin subscription service and to make cloud backups. Today I performed a Cloud Backup and then performed a Cloud Restore. No success. I then tried to Restore my hub using uploads from two earlier Local Backups. Still no success accessing my programmed Apps even though the hub is executing them. My understanding is both Local and Cloud Backups copy the Hubitat hub database (apps, settings, and devices). Restoring a database backup should provide updated apps, settings, and devices.

As a new user, despite the fact I was extremely cautious, there is the possibility of human error and I deleted my Apps. I am pretty sure that most of my Local Backups were a complete database. Any advice would be greatly appreciated. Many thanks, Robert

Welcome aboard Robert, sorry to hear you have had a bumpy ride.

This will likely be something for the HE Support staff to respond to, but in the meantime, it may be useful if you could mention:

  • What platform release you are running, e.g.
  • When you say you cannot access your programmed Apps, are you referring to the Apps page in the web UI? So you are not seeing thing that you have setup, like Rule Machine rules, Button Controller automations, etc? It may be worth providing a screenshot of what you are looking at, just to provide some context, something like:
  • It may be worthwhile looking in the Logs page under Past Logs to see if there is any clues there

Did you click the little > Next to the Rule Machine app?



Good point, there is also a button at the top of the screen to expand all


Yeah I would have never thought that would trip someone up but it happened to someone else just last week so I figured its worth a shot!


Every day this strange UI decision causes user's confusion. Hence: UI Tweak Suggestion


Hello Gents,

Thanks for all your the helpful suggestions. My Platform Version is I was having a problem viewing my programmed rules within the Apps page in the web user interface. As suggested by Jeff and Simon:

  1. Each App has an Arrow Menu , which displays/hides your programmed rules for a given App
  2. The top Control Bar has two double-arrow menu buttons which display/hide your programmed rules for all Apps
    I am somewhat embarrassed for this posting. I was busy upgrading/configuring my LAN and noticed my programmed Apps seemed missing (even though the Hubitat Hub was controlling my Z-Wave devices as programmed). Sometimes when you are working alone on a technical problem you just need a second opinion. Wow, the Hubitat Community responses have saved me many hours debugging a non-existent problem. I sincerely appreciate all of your support resolving my non-existent problem :slight_smile: Robert Castello