Problems with Zooz Power Strip ZEN20 VER. 2.0


I just purchased a Zooz Power strip, and for the first week or so it worked amazingly well. My use case is I have my TV plugged into one port and I have a rule machine rule that monitors that ports power consumption. When it sees the TV turn on (IE: power increases above 50 watts) it turns the other ports on for my Surround Sound receiver, Roku, etc.

This worked flawlessly for about a week. However one day it stopped working. During my investigation I noticed the the power strip is now showing a constant 75 watts of power draw from the outlet (75 watts is what my TV uses when it's on) even if I unplug the TV it continues to display 75 watts. Weirder still: If I click the "Off" button in the device driver, the status changes to "off" and the power draw drops to 0. The weird part is that the outlet doesn't actually turn off! The outlet remains on and I can plug my TV back in and turn it on, yet the driver continues to show the status as "off" with no power draw.

So basically it seems like the driver and the device are not connected at all. But what I don't understand is why does the device driver update it's status (IE: Switch status changes from on to off, etc) if the device itself isn't responding?

I've run Z-wave repair multiple times, rebooted the hub, etc. Did I get a defective unit? Should I just return to Amazon?


Have you tried removing the zen20 from Hubitat, doing a hardware reset and re-including it?

It sounds like the strip might have malfunctioned so we recommend having it replaced since this behavior is not normal at all for the device.

1 Like