Problems with mode with the Honeywell T6 thermostat

I just moved from ST to Hubitat. Most things I like. A few I don't but they can be worked around.

The main problem that I ran into yesterday is with the HVAC smart app I ported from ST. I found that the thermostat will not change to the "auto" mode when commanded in in the app that I wrote. I should add that it worked well in ST and I can command it to change to "heat", "cool, and "off" with no problem. And, auto change over is enabled on the thermostat. I also get a message in the logs that "auto" mode is not supported for this thermostat.

After messing with it a while I found that in the device driver there are buttons for "auto", "heat", "cool", and "off". All of those buttons work except for the "auto" button. The "auto" does nothing while all of the other buttons will switch the thermostat to the proper mode.

I am using the stock driver that comes with Hubitat. I see that there is an advanced custom driver out there but before I try that I wanted to see if anyone else has run into this problem and it there is a fix for it.


I've just replaced my Nest thermostats with Honeywell T6 Pro Z-wave thermostats, and I'm experiencing the same issue with the builtin driver for the T6 Pro. When I attempt to set the thermostat to auto mode, I get the following in the logs.

dev:1042020-10-02 11:59:06.832 am debugauto mode is not supported buy this thermostat
dev:1042020-10-02 11:59:06.830 am tracesetThermostatMode(auto)

Is this a known issue? There are times during season changes where I need both heating and cooling in the same day, so I'd very much like to be able to set it to auto programmatically.


I think it is a known, but ignored issue. I never did find a real fix. I tried the "advanced" driver for the T6 but was never able to get that to work either. Others have but not me. I use the T6 with a custom app I wrote that monitors different temperatures around the house and does the heating and cooling based on that. When a few of the doors are open for an extended period I want to shut the HVAC down so it don't run. That's not a problem, but setting it back to Auto is. For a work around, I just leave in on Auto all the time. To shut the system down, I change the heating and cooling setpoints to a plus or minus 20 degrees from normal to keep the system from turning on. That way I never have to set it back to Auto.