Problems With New Mode Manager

No, it doesn't remove it, only disables it. If you removed it, you can only get it back by restoring a backup from before you removed it. Probably easier to wait for the release,

yeah I can certainly wait until later today or so! I just selected 'skip' on the vacant modes and can make those manually until the release is promoted, thanks Bruce! I love the new format of all these enhancements btw, so much easier to follow the logic and see the coding better!


Mode Manager is still not switching with presence devices for me.

This is what I see in the log:( Cannot cast object '2=Away' with class 'java.util.HashMap$Node' to class 'java.util.Map' on line 888 (method presenceHandlerAnyLeft)

Platform Version:
Mode Manager Version: 2.0.0 (9/27/2022)

Is there anything else you need for diagnosis?
Happy to give you remote access to my C7.


Sorry about this. I know what the problem is: the fixed version did not get into the build. We will get it sorted.


I'm seeing the same error (for the record).

[app:978] ( 2022-09-29 08:03:16.099 amerrororg.codehaus.groovy.runtime.typehandling.GroovyCastException: Cannot cast object '4=Away' with class 'java.util.HashMap$Node' to class 'java.util.Map' on line 888 (method presenceHandlerAnyLeft)

Fix for this just released: Release 2.3.3 Available - #6 by bravenel

Please check it out.

1 Like

Downloaded and updated, first test will be sometime tomorrow. I will report back then. Thanks Bruce!

@bravenel Latest release works...phew! Thanks.

This is the only configuration that worked...setting the 'Presence To Return From Away'. Stops it working. Not a problem for me though!

Away settings are still not working for me under If I check the 'skip' box next to 'Away' under 'Set Mode With Presence Sensors' then it doesn't switch back to the correct mode when someone returns. (I use day at sunrise, night at sunset, and away when all presence sensors leave. If I don't check the box, then the mode switches at sunrise/sunset from Away.

Something is visually off in the UI with the skip buttons on all rows. In the 'set mode at times' table, checking the skip button replaces the time that is set with 'don't change'. That doesn't make any sense.



Checking the skip button next to Away does something similar:

You shouldn't have to un-check the skip button to change those other columns.

Skip in the Times table means to not change the mode based on time when the Skip box is checked for the current mode. Ordinarily this would be for Away mode. That means, when Away, even if the time becomes time for Night mode, don't change to Night mode, but rather stay in Away mode. This is usually the way one wants this to work.

Skip in the Presence table means to not change the mode based on presence when the Skip box is checked for the current mode. This is a more unusual setting, and is meant to leave a mode set irrespective of the comings and goings of the presence sensors. An example would be a Guest mode. Suppose you use Guest mode for when you have guests in the house, and you don't want the house to change to Away when you leave, or to change out of Guest mode when you return.

Do you have Time set up? You would only use Return From Away if there are modes set by time as the reference for what mode set when you return from Away.


Sorry, MM isn't throwing an error now but not seeing the return of the Presence device.
This is how my Mode Manager is setup:

From the Fob Device page:

The Fob Departed:

The Fob Returned at 11:43am but didn't set the mode from Away to Home. -Joel

Did you update to 125? That fixed the problem with line 888 error.

Yes, the snippet just included the time prior to this.

I'm still confused. The behavior I want is:

At sunrise, switch to Day unless Away
At sunset, switch to Night, unless Away

When all presence sensors leave, switch to Away
When any presence sensor returns, switch to Day or Night, depending on time

In the old mode manager that was achieved by the setup I am using in the new mode manager. Am I supposed to be doing something different or is there still a bug?

Again, what I'm seeing is that if I check the 'Skip' for my Away mode, then it doesn't end the Away mode when one or more presence sensors return. If I don't check the 'Skip' for Away mode, then it will come out of Away at sunrise/sunset even if all presence sensors are still gone.

This is how you want it:

My wife left for a 2nd time and just returned, events show departure and arrival but mode stayed Away (again).

Screenshot 2022-09-30 135842

The app is not showing any presence events. Check the Event Subscriptions on the App Status page, and make sure those show Durango fob.present and Durango fob.not present.

In the logs, select both the app and the presence device for filters in the logs, so we can see both.

Is this what you were looking for? The top entry set to "Home" was when I set it manually. The snippet is again starting from before I updated to

Are you on release The error you're showing suggests not.

Oh, sorry, that was from before. Before, due to that error, it was not handling presence arrival events correctly. It should now.