Problems With New Mode Manager

I'm having some problems with the new Mode Manager β€” specifically with modes being set by switches. I thought it might be because I imported the old mode manager into the new, so I completely removed the new Mode Manager, reinstalled it, and started with a very simple setup.

In the new Mode Manager, I have two modes set up: Home and Test. I thought what should happen with this setup is for Test to turn on if "Switch - Test Mode" turns on, and Home to turn on if the same switch turns off.

In the logs, I can see that the Test mode turns on when the switch turns on. But, when I turn the switch off, Home comes on only for a split second, then Test comes back on.

This is exactly what I was seeing before when I imported my Mode Manager Legacy settings to the new Mode Manager. Switches On seems to work OK, but Switches Off doesn't.

I also have RM rules that send a notification to my phone when mode changes. I'm getting multiple notifications for each mode change in the new Mode Manager. This doesn't happen in Mode Manager Legacy.

I've gone back to Mode Manager Legacy for now because it's all working OK.

I will check it out...

I can see what the problem is. Faulty logic for sure. Fix will be in the next release.

When the new release comes out, you will need to hit Done in the app to get updated Event Subscriptions.

4 Likes

Thanks! That was quick.

Yeah, not a big issue. And, it should work even without hitting Done.

3 Likes

2 posts were merged into an existing topic: New mode manager problems with presence

Was the fix pushed out already? I seem to be having this exact issue.

2 Likes

That works a lot better now! thanks!

1 Like

Thank you!

Hi,
I am having an issue with my 'Pause Rules' & 'Resume Rules' statements. Prior to the update to 2.3.3.12x I had some Pause and Resume statements in place for Rule Machine type rules. Post upgrade I have lost the pointers to my Rule Machine rules. When I try to reinstate them only my Rule Machine Legacy rules appear in the list of rules (even though only rule type of 'Rule Machine' is available for the selection of type).

Thanks in advance.

Please look at the action to Pause/Resume rules. Do you see this pull-down menu? Please show a screenshot:

An additional data point is the the rule I am editting is a Rule Machine Legacy rule. (I did not realize that in my OP). Here is an editted view of to show a sample of my rules:

Here is what I see while attempting to edit (i.e. insert) into this rule:

which shows my Rule Machine Legacy rules:

I do understand that Legacy rules cannot incorporate 5.x rules, so I think my sole issue comes down to the misleading 'Rule Machine' label in the drop down box

Rule Machine Legacy didn't know about later versions of Rule Machine.

I am also experiencing unexpected behavior from the new mode mgr compared to legacy, but I see on this thread above that there are sort of 2 main aspects in table - but I have several modes for being home and away (see screenshot) which I leverage for things like arming cameras, security lighting, etc in many of my rules.

For example, in Day mode - and Ahren leaves, the house switches to Daytime Vacant even with me still being home. If we all leave, it has switched to Daytime Vacant, though not reliably, and doesn't update to Day when one or both of us arrive back home...?

@bravenel What is the recommended approach with the new and improved MM?

First of all, be aware there is an outstanding bug that will prevent this from working properly until the next build.

Do you want to modes to be set based on time? Without you necessarily leaving / returning?

ah - ok thanks for the heads up.

I do leverage time as a factor for setting modes, but always tie to that decision if we are home or not. Would it better to just create a RM rule for this until the bug is fixed in MM2?

Or is it feasible to revert back to the original MM/legacy?

You can revert easily. New release with fix due out later today, most likely. Bug affects presence sensors setting modes.

1 Like

How do I reinstall the legacy app? I added the new one obviously and think I might have removed the legacy or it did it automatically..?

No, it doesn't remove it, only disables it. If you removed it, you can only get it back by restoring a backup from before you removed it. Probably easier to wait for the release,

yeah I can certainly wait until later today or so! I just selected 'skip' on the vacant modes and can make those manually until the release is promoted, thanks Bruce! I love the new format of all these enhancements btw, so much easier to follow the logic and see the coding better!

Download the Hubitat app