Problems with button controller 5.0

I get this error every time I'm trying to create some rules for a specific button:

org.codehaus.groovy.runtime.InvokerInvocationException: hubitat.exception.NotFoundException: Child app not found for namespace: hubitat and name: Button Rule-5.0a (mainPage)

Unexpected Error

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: Child app not found for namespace: hubitat and name: Button Rule-5.0a

It happens when I'm adding a button, for example, button 1, Pushed. As soon as pushed is selected, the crash above happens.

Could you share a screenshot of the rule that you are trying to create and that generates the error?

Have you tried a reboot? Some people see this error immediately after updating (when the child app "version"/name changed, as was the case with one of the 2.2.8.x updates and the original release itself), and a reboot has resolved it.

2 Likes

I doubt it will tell you much as i can't get to the point where I create the rule.

When I set the button operation, the crash happens.

I'm pretty sure the device has been rebooted a couple of times since the first 2.2.8, but i guess it's a place to start.

I've updated 3 or 4 times with the minor updates, and i have created one 5.0 controller before this, which worked fine.

I’ve tried to reproduce but am not getting a crash. Can you share information about the button controller (Volume Button)? Is it a Virtual button? What driver are you using?

The reason I'm asking is because one of those minor updates bumped it from 5.0 to 5.0a, so if you haven't done a reboot since then, it could be the source of this problem (even if you have since the original 2.2.8 with version 5.0). The fact that this happens is probably a problem in itself (that hopefully they can address), but a single reboot afterwards has fixed it for any case I've seen here.

And you probably know this, but for anyone reading who doesn't: Settings > Reboot Hub. Don't just pull the power. :slight_smile:

1 Like

@Sebastien

I tried what you said… and it worked.
I can create a button controller now :grinning_face_with_smiling_eyes:.

Sorry about wasting your time, but huge thanks for the heads up.

1 Like

Download the Hubitat app