Problems adding devices to Echo Skill

I started exploring my new C7 hub yesterday (another SmartThings refugee), and as a first step migrated a single dimmer switch (Fibaro Dimmer 2) and Fibaro motion detector that were both in the same small room.

(Step 0 was updating the hub to the latest firmware - it's on

At one point these were added, had a simple rule turning the dimmer on when there was motion, and the dimmer was responding to Alexa commands via the Hubitat Echo Skill.

But...because of driver problems with the dimmer (which I'll post about separately elsewhere), I finished up removing the dimmer from the hub, factory resetting it, and rejoining it to the hub. With hindsight, I didn't remove the dimmer from the Echo Skill's devices list before removing it from the hub itself (checking later it did vanish from that list after hub removal, though).

After that the dimmer's again responding to software commands, but the Echo Skill has stopped accepting changes to its devices list; you can get into the list of device checkboxes in the Skill and make changes to that, but when you press the "Done" button you get a brief display of the modifed list on the app's page, then the browser drops back to the App List page. When you revisit the Echo Skill app page, the checkbox changes haven't been saved.

I've tried uninstalling the Echo Skill, reinstalling and adding devices (with hub reboots between each step), and tha hasn't helped - any change (which at this point involves adding any device to the list) fails to stick.

Any advice on how to fix this problem would be appreciated!

I don't have a C7 But Whenever I have an issue with communication with my echo stuff, I go to the alexa app and log off and back in. Also after go to the alexa app and remove the device from there and rediscover. Sometimes I just "forget all" in that app and let it find everything again. Depending on how many routines you have set up in alexa, it may not be feasible, but definitely make sure you remove any old devices from the app as well. Then try redoing the device in the skill.

Thanks for the suggestion April.

I've tried disabling and re-enabling the Hubitat skill in the Alexa app, and this did make a difference; the motion sensor has now appeared in the device list in the Alexa Skill app on my hub.

Unfortunately no difference has been made to the ability to change that list - it's stil behaving as before, and failing to record any changes. :frowning:

(For completeness I tried changing the hub Skill list with the Hubitat skill in the Amazon app left disabled - same behaviour as in the previous paragraph.)

Now you say that you are in the HE Alexa App and that you are checking boxes and then pressing the "Done" button. At the bottom of the dropdown checkbox window there is an "Update" button. You need to press the "Update" button before the "Done" button. Disregard if you are already doing this.

1 Like

Gah - how embarrassing!

Thanks David - presumably I had been doing this yesterday, as I was adding devices to the list again. But somehow seem to have convinced myself overnight that the "Update" button was equivalent to "Refresh", so didn't need pressing if all the devices were already in the list. D'oh, and thanks again.

Your welcome. It feels good to help someone rather than getting help all the time.

1 Like