Problem with Sonos Driver

Maybe the problem is not related to the file accessing but to the Music Player.
My old rules which are using "Speech Device" are still working fine.
Here is on very simple and still working:

All my rules based on MP3 Files stopped announcing.
But per your suggestion if I use URL in the Explorer files are accessible.
I created a very simple test rule (tried in RM Legacy but instead rule
was created in RM5):

This rule does not work at all.
Log for the rule looks good:

But there is another log for Speaker with errors:

So, something is definitely broken:

  • accessing files maybe OK.
  • playTrack does nothing
  • Speak on Speech Device produces an error
  • Speak on Music Device also produces an error

Everything was working OK up to and became broken in
(and maybe even in

In addition I was debugging my August Lock (I have a thread for this effort).
In I was able to pair lock with HE without any problems.
It did not work reliably but pairing was OK.
I updated to and Lock stopped working all together.
I remove lock from HE but now I absolutely cannot pair it back.
Every pairing attempt results in creating hard to remove ghost device.

What kind of speech device is this?

If this is Z-Wave lock, be sure to factory reset it, and also do another Z-Wave exclusion on it.

I have two IKEA Symfonisk speakers.

Yes, this is August Pro Lock with Zwave.
Factory reset is not really desired option - there will be too
many annoying steps to get everything back.
Lock is working perfectly fine except for the integration with HE.
But OK, I will try factory reset it.

Driver is throwing an error. What driver is it?

Speaker Driver is built-in "Sonos Player"

Might you be having issues with your IP addresses getting automatically reassigned?

Many home automation things that use wifi with the Hubitat will work WAY better with a fixed IP address, not a random DHCP one. Sometimes, it can be tricky to force that--start with your router, by trying to assign fixed addresses.

For Sonos, that "Device Network ID" (C0A81460 above) is actually the IP address in Hex. If the device is at a different IP, you should edit that manually to update the address.

COA81560 -> C0.A8.15.60 ->

1 Like

This is not a case.
All my IP Critical Addresses are MAC-to-IP mapped in the Router even
thought the device is configured to use DHCP
You are absolutely correct about HEX representation of IP:
COA81460 -> C0.A8.14.60 -> <-- This is a valid Sonos IP Address

Just be clear on the issue.
I have two different methods for announcements.
First (and it is/was still preferable) is to use Speech/Music device like this:
This is still working with existing RM4.1 rules even under
however started to spit a driver error when I created very simple
test rule im RM5 (there is no way to create new rule in RM4 with
Second method is/was to use MP3 locally stored files with Custom Actions:

I had to switch to this second method because first method started to play
wrong announcements. I was told this was because Russian characters are
8-bit. Everything was working fine until I upgraded hub to 2.2.9.(134, 137)
Now second method simply is not working at all (neither in existing RM4
rules nor in new RM5 test rule) and there is no any related errors in the logs.
Problem or problems are clearly related to the 2.2.9.z HE SW.

I have asked the engineer to look into this.

Perhaps you should roll back to 2.2.8 until the above happens.

Try exporting an existing RM4.1 rule, then importing it into a new rule. Then, delete all the stuff out of it and add what you want in your new rule.

I guess, this is my best option as of today.
Unfortunately there are to many problems popped up with 2.2.9
But I was waiting and hopping for the solution.
After rolling back to 2.2.8 I will not be able to test potential fix(es).

Another potential option(s) to keep everything up and running
but to test all upcoming fixes is to use ether my retired C-5
(this one is on line but simply idling) or to setup brand new
spare C-7 (still in a box).
Please advice what will the best option to nail down problems?

We are seeing very few problems at this point. Some that you report as problems turn out only to be your misunderstanding. I am happy to explore problems that are real, and we will fix them. Please let me know specifically each problem.

I am very limited to screwup things on working hub.
WAF is the reason.
I already had some "greetings" from my wife when some
announcements simply disappeared.

I am surprise to here this.
What I am misunderstanding?

I am happy to explore problems that are real, and we will fix them. Please let me know specifically each problem.

I will be very happy to get your assistance with debugging a problem(s).

One is this Sonos related.
What I am misunderstanding here?
First I reported (a while ago) incorrect announcements were played.
Happens to be related to 8-bit Russian characters.
I closed my eyes on this problem and found a work around with MP3 files.
This was working until update to the 2.2.9
Is this my misunderstanding of something or real 2.2.9 problem?

Yes, I did not dig too deep and reported potential problem with accessing
local files. This is because I had a problem if I misspelled file name.
No error was reported but of course no announcement was produced.
That is why I thought local files became inaccessible.
But it looks something else became broken.
Again, there is nothing in the logs but announcements stopped working.

Second one is August Lock related.
Frankly this lock never worked reliably with HE.
But it was somewhat working.
It became a complete disaster after upgrading to 2.2.9
Is this again my misunderstanding?

As already said, waiting for engineer to look at Sonos issue. Why repeat that again?

This already has its own thread, and doesn't need to be repeated here.

Look, posting the same thing multiple times doesn't help get solutions, just aggravates those trying to help you. Give it a rest.

1 Like

I got a message, I am sorry, I will be very quite.

I just setup a 5.1 rule to play an mp3 file from local file through my Sonos. Works fine:

playTrackAndRestore also works. I suggest you see if this works from the device page. If it doesn't work there, then there is some other issue you have with how the device is setup. Remedy for that might be to remove the device and then set it up again.

1 Like

Just tried from the Device page:

The URI is:
File is accessable.

Clicking on:

playTrack - nothing happens
playTrackAndRestore - again nothing
Speak - Works as expected (said "Test")

But if I click on playTrack or playTrackAndRestore after clicking on Speak
it says "Test" (word I used to test Speak button).

So, I'd say remove the device and set it up again.

My test shows (a) Sonos driver is working as expected, (b) Rule 5.1 is working as expected, (c) local files are working as expected, and (d) is working as expected.

Please email me the mp3 file that's not working.

This also works: