Problem with c8: cannot remove Z-wave device

I.dont know if its an 800 firmware or os issue.nut i can guarantee you this message is incorrect

The troubled device is unplugged. Any ideas .


More interesting rebooted hub still.cannot remove. How.can it say rwmove failed no reply that seems backwards.


Is this a relatively old Z-Wave database? This smells like corruption that was more common early on with 700-series controllers, before SiLabs switched away from their proprietary database format. A migration, as you may have done to the C-8, won't fix that but rather just bring it along. Aside from waiting and seeing if that helps, I'm not aware of any solutions without a secondary controller (which I wouldn't recommend if there aren't actual problems).

no i dont think it is corruption but it is old.. but i have in the last few weeks done a soft reset and restore which should have fixed any corruption and there has been no sudden power outages on the hub without shutdown as it is on an ups.

since the device still technically worked but recent didnt and spammed my network with tons of messages. i was able to remove it by plugging it back in near the hub and luckily the normal exclusion did work.. phew.

I'm just saying it's consistent with the symptoms of corruption reported maybe a couple years ago. A soft reset will not help. That is the hub database. I am referring specifically to the Z-Wave radio database.

Glad you got it removed though!

1 Like

crap so how is that fixed.. i though the conversion during a new build a month or two ago converted to the new format,, i have almost 100 zwave devices.. dont really want to try to redo all that.. that would be weeks of torture....oh crap

A radio firmware update switched the Z-Wave database away from the proprietary format, which was "prone" to corruption (probably not really that often, but you'll definitely hear about problems here, and more than the new format, which I'm not sure I've seen this issue crop up on).

However, I'm pretty sure it only applies to new databases, created after this change. At the very least, it doesn't appear to have helped every case where this had already appeared. Starting over would for sure get the new format, but if you aren't actually experiencing problems, I'm not sure that's worth it. For specific problematic nodes, a secondary controller normally works where the hub's SDK-based methods don't, though Support doesn't officially recommended that.

1 Like

guess i need to get the zwave stick working on the c8.. i have an older 500 series and i have the driver installed and it ported over from the c7 to c8.. i keep it disabled to not cause issues but not sure it will work transparently on the new hub,, assume the ids are different.. i havent had to boot it up in probably over a year.. the old force remove methods had been working last time i tried when a device totally failed..

i think it was one of the ge wall switches where the radio died due to power fluctuations.

Just curious, are you saying:

  1. Z-Wave items moved into the C8 by C7 to C8 migration (using the Hubitat cloud) will have the device database in the pre 800 format?
  2. Devices paired to the C8 will have these devices in the "new" format.

Do you know if the C8 hub will have two formats for the Z-Wave device format? or will the existence of a pre 800 format will force all new devices to the old format?

This isn't 800-series-specific or related to the C-8; the update was made fairly early on in the 700 series and made available to Hubitat with one of those Z-Wave radio firmware updates. A migration will take your database as-is -- no cleanup/conversion. (I could be wrong about the update itself not changing the format, but I do beleive it won't resolve corruption either way.)

1 Like

I rarely trust myself, but I have a memory of us being warned about a database format change in an update that would mean we couldn't (or shouldn't?) go back. Maybe I'm making that up???

I did find this comment about a database format change in 2.2.5 but that sounds like a hub FW update not a Z-Wave firmware update...

Or this...makes it sound like the database update was applied, not optional.

1 Like

This has happened (at least?) once with the main/hub database, but again, this is just the Z-Wave database, a separate entity.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.