Problem with Button Controller App & Iris 3460-L

I have several Iris 3460-L buttons. I had one working fine until I had to reset all my devices yesterday & had to remove the old version of Button Controller.

I factory reset the one working button I had before yesterday.

I paired that button device using Iris v1 Zigbee. HE found it and it initialized as normal, I added Button Controller app which appears to be a newer version than I was using on this button device before.

Anyway, I started configuring the button:

  1. I named the Button "PANIC"

  2. I chose the button in the list in Button Controller was there as normal with along with 2 keyfobs.

  3. On the next step BC was asking "Define actions for PANIC"
    Next choice in the app was "For this button action ... Select button number* & then I had a drop down box with "Click To Set"....I clicked this box & it just said "click to set"...I could never get it to
    take a number such as # 1 or just kept saying "click to set"...never an option to actually enter anything at all.

  4. I could not leave that box blank as HE would give me the "required fields/ missing..." dialogue.

My only choice was to remove this child instance of Button Controller & try again...I get the same problem.

So I then uninstalled Button Controllers app & tried again...reinstalled all...same problems.

Next idea was to "remove device" and unpair the 3460-L from HE...uninstall Button Controllers App & then factory reset the Iris 3460-L.

Next I tried pairing the 3460-L button and now, HE finds the button again, but it just says "Zigbee device found with ID (blah..blah..) & just sits there "Initializing" never fully ID's the device
as an Iris Button....just sits there "initializing"...I waited 15+ minutes & aborted the pairing...reset all and tried again...same hang up on "initializing"...

So next idea was to try another brand new/never used or paired 3460-L button...I get the same results as all outlined above.

If the button does finally "initialize" HE says it is just a "Device"...So I then go into that devices settings & use "Iris V1 button" driver but this never works...button does nothing...nothing shows in the "configure" or "State" section of the buttons setting in HE devices.

After many resets & re-pairs of BOTH of these two buttons, they either hang up on "initializing" or they only identify & set up as a "Device"--they never are recognized as an Iris V1 Button.

I did not have this problem with the "old" button controller app as I was able to configure the first button with settings for "use held", etc...that is, the first button was indeed working fine before I had to delete old BC & devices yesterday.

Any ideas on what to do? Why won't Button Controller let me configure the button number if it does finally "initialize" and load a driver?

Stumped again....

I think that model is actually supported by the driver "Iris Button Controller" as I believe that is a gen2 button. Try with that driver and see what you get.


I tried that and the button did indeed initialize with "Iris Button Controller"...thank you.

However, I am still back at the same problem in "Buttons Controller" when trying to set this button up. It still will not let me "Select Button Number" in the "click to set" box with the drop down arrow on the right side of that entry box. I "click to set" but I still cannot enter a just keeps showing "click to set"....and again, if I leave that box blank & click "Done" HE throws the "Fill in required missing fields" error.

I remember the previous version of Button Controller had a slider for me to choose "Use Held"...;this version doesn't that I can see.

In this version of BC, when I choose "create new button controller 3.0", here's what I get:

I can only name the button controller, which I do...

then I get "Select Button Device*"....which I do from the list of my 2 keyfobs & 1 single button...

So after I choose the device button to use..
Then the problem starts in BC as I get these:

Define Actions for Panic Button

For this button-action...

Select button number *

Click To Set (this ia a box with dropdown arrow)

This "click to set box" is what will NOT take any input whatsoever from me...if I click the box it just says "click to set" again...& as I said I can't leave this field blank & move on to "DONE" as I get the "required missing fields error with * " dialogue.

I'm close but not quite there yet...thanks for any input on this problem!

I don't use the built in BC app but this sounds to me like the button device may not have one of it's states properly initialized. On the device details page of you Iris button, under current states, there should be one call numberOfButtons. Most button related apps use this to know what options to display for configuration. If it's not there, try hitting the Configure button, wait a few seconds and refresh the device page to see if it shows up.

1 Like

Here is a pic of the button that I did finally get to be discovered via Zigbee discover ...I tried the config and then refresh and nothing ever happens>

Are you just using Rule Machine to control your buttons rather than BC?

I use my own app..Advanced Button Controller...but it won't work properly for you either unless the numberOfButtons attribute is set. It seems like you are having a driver issue. Hopefully @mike.maxwell can point you in the right direction.

Oh..and btw...when I said refresh, I meant to refresh the web page and not hit the refresh button.

I tried refreshing the web page itself a few times, then the refresh button go. I tried another of the 3460-L button devices I have and and it never gets discovered anymore though
it did one time or two last night.

One the one button that is discovered in the pic I posted, I assume it is a driver issue. Thanks Stephen....I'll play around with it some more today.

The 3460-L is not an iris v1 device, it needs to be discovered using the normal zigbee discovery, not the Iris V1 zigbee discovery.

I did discover it via normal zigbee method after it was first hung up in "initializing" mode using V1 Iris Zigbee last night.

At this point, it is discovered in Normal Zigbee and the pic I posted of the device is how it is currently "configured". Is this perhaps a driver issue now as the device is discovered properly? It is shown as an Iris Button Controller in my device type.

As @stephack pointed out above, until the device's numberOfButtons attribute is set correctly, it will not work properly with most button controller apps.

So should I remove the button from HE, factory reset it and try again to see if it picks up driver & attributes? Almost afraid to remove it as the buttons never seem to be discovered agin in my case. :slight_smile:

Did you manually change the driver type to Iris Button Controller?

Last bight when It was properly discovered Zigbee, I can't remember if it picked up as Iris Button Controller or if I set that.

That's what I would do at this point. It should automatically get the correct driver. If it doesn't and picks something Generic post the results here and tag Mike.

Another thing to consider if you continue to have trouble pairing is mesh issues. If the button is far from the hub and you don't have any zigbee repeaters close by, you can run into issues pairing and communicating.

I removed the one button that was finally discovered from HE, reset if by pulling battery for 20 seconds, sliding battery tray back in while also holding down button for 2 seconds after insertion of battery tray--this according to Iris factory reset instructs.

As I expected, the button never gets discovered again, just like the two other buttons that once removed from HE, they never seem to get found again.

One thing I have noticed on the reset of these buttons--when I insert the battery tray, I get a "red" led light for a few seconds that goes off..anyway after the 2seconds of holding down button for the reset, I release button & try to discover using normal Zigbee.

I remember on all of these buttons (that are now not discoverable) initial pulling of the plastic tab as these were new buttons, I would get a BLUE led..only get RED when I pull battery & reinsert.

So, at this point I decided to try my last new "virgin" button, still with plastic tab covering battery.

I pulled the tab, get the flashing BLUE led momentarily...all seems fine at this point.

Next, I go into normal Zigbee discovery & HE finds the new button & says "initializing"...then it just gets stuck in initializing mode like all other buttons have done a few times.

Sooo....I pull battery, wait a while..then go into factory reset and this button, like all others, just gives me a momentary RED led flash as the battery tray is inserted..shouldn't this be BLUE??

HE nevers discovers the button again..I suspect these are not properly resetting but I don't really know for sure.

It seems like it is like rolling dice on whether these buttons get discovered or reset..I dunno.
I even replaced the original factory 2450 batteries with new Duracell batts.

I'm in search of a good exorcist right now for these :slight_smile: but seriously am about to just resolve the fact that my HE system was NOT meant to have buttons. :slight_smile:

The reset procedure requires holding the button down whilst inserting the battery, not pressing it after insertion...

That's what I did...held button down for 2 seconds while inserting battery tray.

I'll tell you, these are buggers to reset. You have to get the timing just right or it won't reset.