Problem - new hub - stopped working, won't update to latest firmware, more

Just got new Hub last week. Only loaded a few devices , setup both our phones and accounts for presence, added package mgr rules engine etc. No problems it seemed.

Yesterday tried adding the Alexa skill thru alexa app - it kept giving me unsuccessful ... ok ... no biggie ...

Then, I saw there was a firmware update - tried several times I am on .122 - it just stalls ... nothing.

Last night later the automations I had stopped working ...

I did a soft reset yesterday and reloaded a backup from earlier. Nothing.

Trying again the firmware update - nothing. Tried controlling a light I had on there - nothing.

Help plz !

Your symptoms of "Alexa - unsuccessful" and "Firmware update - stalls" both point at the hub's inability to reach the Internet.

Hubitat doesn't REQUIRE the Internet to function BUT it does use the Internet to get updates, time, and make your dashboards available via the cloud if you allow that. Cloud integrations, such as Alexa of course, need access to that cloud.

You home's LAN/WiFi/ISP configuration will control that, the hub gets no vote. :slight_smile:


So - the hub is plugged into a network switch which is certainly live and connected to the internet. My pc is on the same switch. And - this WAS working but stopped. I did get a 500 network error though once. Any ideas of what I need to change or do? The network switch is certainly live and active I just plugged a laptop into that same port and no problems with it. Is there a place I can log a trouble ticket with Hubitat other than posting here?

dns issues maybe

1 Like

Are you using a Static IP on the hub?

I will tag @support_team for you.


I am on static ip

Might try a network reset to see if that helps:


Can you switch back to using DHCP? And see if that makes a difference. Alternatively, change the DNS to be (i.e. Cloudfront's DNS).

1 Like

Yup - you called it - that did the trick! many thanks for taking the time to help me out.


Did network reset that fixed the firmware problem ...

1 Like


FYI - that switches from a static IP back to DHCP.

Yes - I immediately set it BACK to a fixed IP. It is all working now I don't know enough about HE to know exactly what did it but it would not go until I did the network reset - then back to DHCP ... I did a firmware update with DHCP it worked. Then switched to static IP again - and the problems I was having getting Alexa installed ALSO then worked.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.