Problem Controlling Yale 446 lock on Smartthings Hub

I have set up HubConnect 2.0. My Hubitat sub is the server and a Smartthings V2 hub, fully up to date, is the remote. I put in the proper driver for my Yale YRD446 lock and it worked, sort of, for a while, but now nothing happens. I keep getting an error message:

I have tried rebooting both hubs and everything else seems to work fine. Anyone have any ideas? Cordell Jeppsen

Clearly a Hubitat Hub in that screen shot and it's running HubConnect Server...

After that is cloudy... :slight_smile:

Dev:44 is the lock, but those line numbers have nothing to do with HubConnect's Lock driver. It's only 190 lines long, so line numbers larger than the driver tell me quite clearly, I'm not looking at messages for the HubConnect Lock (stub) Driver.

I was using a driver provided by boys on the ST hub. I replaced that with the built-in generic z-wave lock driveer supplied by ST. It made no difference. The lock continues to run properly on the ST hub. I may just have to give up on this and leave the locks alone so far as HubConnect is concerned.

Ok, so what is "Dev:44" and the driver it's using on Hubitat? Because it's not the HubConnect Lock Driver.

In the Devices section of Hubitat it says: HubConnect Lock. The device is a Yale zwave lock YRD446. When I selected it in the HubConnect client in Smartthings it told me to load the HubConnect Lock driver.

but the HubConnect Lock Driver (HuConnect-Lock.groovy) has only 190 lines of code:

Screen Shot 2020-08-31 at 4.08.24 PM

So where are lines 200+ coming from?

Screen Shot 2020-08-31 at 4.10.22 PM

I just noticed I seem to have two instances of the HubConnect Lock driver loaded. Could this be the problem. Can I just delete one of them or do I need to do more?

Incidentally, both instances in my environment show 234 lines of code for the driver.

That's the SmartThings driver, deployed on Hubitat. :frowning:

Look for Hubitat drivers under "Universal Drivers"

Line 18 of the driver you're using will have:

def getDriverVersion() {[platform: "SmartThings", major: 2, minor: 0, build: 0]}

It should be:

def getDriverVersion() {[platform: "Universal", major: 2, minor: 0, build: 0]}

What I'd do is delete both Locks on the Hubitat side, then in Driver code, delete both. Then install the correct one from HubConnect.to

Then, go back into HubConnect on ST and pretend to re-select the Lock... when you Done all the way out it will send across the selection list and rebuild the 'mirrored' lock.

OK. I have done that exactly. How long does it take for the devices to appear in Hubitat? I've been waiting several minutes.

4 seconds.

So, if nothing changes for 40 minutes what do you suggest? I have rebooted both hubs.

PM a Technical Support Report, please.

OR
Open a Ticket on HubConnect.to and include the Report there.

Sorry if I'm making things difficult. How do I prepare the report?

HubConnect Server app: HubConnect Reports: Technical Support Report.

Screen Shot 2020-08-31 at 9.07.28 PM

First, delete the message with the Tech Support Report.

Second, you have no devices selected on SmartThings.

In your Report, in this area:

============================ Jeppsen Home (Instance) ============================
appId: 156
appVersion: [platform:Hubitat, major:2, minor:0, build:9801]
installedVersion: [major:2, minor:0, build:9801, platform:Hubitat]
.
.
.
-------- Inbound Devices --------
incomingDevices: 0
deviceIdList: [443/api/smartapps/installations/a1cf7097-c979-49c7-b84d-2b3e4192d8d7]

It shows ZERO incoming devices.

On mine, the same Report shows:

-------- Inbound Devices --------
incomingDevices: 1
deviceIdList: [443/api/smartapps/installations/605e7a07-9606-4110-8530-093a2ad1b1dd, c7f36275-a2dd-4a83-9fd5-f4ea7d09e567]

And when I delete the one device I'm sending from ST to Hubitat, I get this:

-------- Inbound Devices --------
incomingDevices: 0
deviceIdList: [443/api/smartapps/installations/605e7a07-9606-4110-8530-093a2ad1b1dd]

Which matches yours.

Therefore, I can conclude: You have nothing selected in the ST Remote Client to be sent to Hubitat.

I suggested:

My assumption there was that you deleted the Hubitat pieces and left ST alone. Thus when you went back in on ST, the Lock would still be selected, no need to select it/them again. I suspect though that you did 1) something else; or 2) you didn't pretend enough... you need to drill down into the menu system to the point where you'd see the names of locks. If none are selected, select one. If one is selected, that's good enough, click Done and Save to the point where you're seeing the list of SmartApps in the Automation screen.

I decided to remove all the devices from Hubitat connected through HubConnect. I left the drivers installed. After doing that I checked in Smartthings and my 6 devices were still selected. I went down to the point where I selected the name of the lock and it seemed I had to change something in that list because if I didn't the "Done" option was greyed out. I added another lock and clicked Done. I following all the prompts out to the last Done. After a few seconds all 6, now 7, devices appeared in Habitat. I tested them all and they worked just fine.

Thanks for your patience and help. The wonderful thing about this is that I can take my time moving devices over to Hubitat. In the meantime my automations can be removed from Smartthings and recreated in Hubitat where they run much faster even for devices in Smartthings that still have drivers in the cloud.

Download the Hubitat app