Power Reporting on Generic Zigbee Outlet Issue

Thanks!

Apparently nobody reported it or caught this bug. I haven't seen any widespread threads about this on the forum, and the first report about this particular device was 5 days ago.

So not sure how this has been "festering"?

You may be correct. I might be conflating my zwave pendingswitch issues that still dont work. Plenty of talk there. Zwave pendingSwitch

Is there any date when 2.2.5 with this fix is expected to be released please?

@mike.maxwell
Also for my Blitzwolf BW-SPH13 the power reporting doesn't work. Here is the device info:

  • endpointId: 01
  • application: 41
  • manufacturer: _TZ3000_g5xawfcq
  • model: TS0121
  • softwareBuild:
  • inClusters: 0000,0004,0005,0006,0702,0B04
  • outClusters: 0019,000A
  • endpointId: 01
  • profileId: 0104
  • driver: v1.0.1.1123
  • powerCluster: 0702

Just wanted to report it, not sure if this is the correct place.

1 Like

After the last update, the SPH-13 started reporting the wattage again, but this time is 10x lower than the actual consumption. So if it shows 170W, it's actually 1700W.

2 Likes

How is it working on 2.2.6 for you ? I have two of these SPH-13 and they do not report energy. Before 2.2.6 I was running 2.2.4.

Any status on this?
I have the same outlets. They seem to be the only ones that can handle the peak power of our washing machine.
Reported power seems to be dividend by 10. Also no detailed reporting (behind the comma).

can all users having reporting issues with SPH-13 please copy and paste a screen shot of the data section of the driver into this thread?, thanks.

Here is mine (that is connected):

Summary

EDIT: Just plugged in my second one as well. Here is that one:

Summary

It actually looks a bit different for some reason ?

I don't think you clicked configure on the second unit after changing to the outlet driver.

I guess you are right. Just did that and now I see more, but still not the same as the other one ? It does however work as on/off.

All the bits we write are the same, I can't speak for the other cruft left over from someone else's driver.

Ok, understood. But does this information help in your investigation into your driver, or do you need something additional from me ?

I needed the fingerprint data, which you provided, thanks!

1 Like

I have the same issue that my power outlet reports power only when I click refresh on device settings. I have set "Enable automatic power reporting" to 1 W and I have also tried other values there too.

Here's my device details:

@mike.maxwell

I'm still seeing very weird power results in my Samsung SmartThings power socket.

Every 2nd data report is in the range of 65,000 w.

Here is the data. Generic zigbee outlet. It's been like this since 2.2.4
image

Huh?
I'll need to see the live logs of this, with both debug and text logging enabled...

Hey @mike.maxwell. Is this sufficient?

Edit: I'm not running a superComputer here.

It is interesting to note the reported value (65809) minus the actual value (273) is 65536, or 2^16. That seems like some sort of 2-byte shift bug.

2 Likes

Download the Hubitat app