Power down to repair Z-wave

My self induced Z-wave catastrophe. I have had a well performing Z-wave mesh and Hubitat that has been performing without issues since the early C-7 problems were resolved. A few days ago I tried to create a rule that would be a work around for the Lifx bulbs inability to utilize “start raising, start lowering and stop changing” using the button capabilities of an Inovelli Red Scene switch. I created a rule that would increase the level 10% every 0.3 seconds when a button was pushed and would stop when released. For some reason it did not work. I was distracted and forgot about it. Over the course of the next day or so the rule continued to run and at some point I noticed that every Z-wave was getting very slow or unreliable. Looked at the hub and saw a message to the effect that the cpu was overloaded and the database was full. Looked at the logs and saw that Z-wave had crashed and was able to see that the culprit was the misconfigured runaway rule. No worries, delete the rule and reboot.

Then, almost nothing z-wave worked. Looked at the Z-wave Topology table and it was literally almost all red. No device had a neighbor. Everything was directly connected to the hub which means not much was. The hub is not centrally located. A couple of Z-wave repairs made little difference. I had visions of resetting and reconnecting most of the repeating devices from the hub out along with rebuilding a myriad of rules. Then I recalled reading somewhere that turning off the hub and disconnecting power for about a half hour would clear the Z-wave routes and they would re-establish themselves. So, shut down, powered down, thirty minutes with power removed, powered up and pretty much back to normal. The routes have changed very little over the last few days and seem to be as good as a Z-wave can be.

Yeah a power down reboot is generally required to clear the Zwave cache - should only need 30-45 seconds though for future reference.


You might find post #4 to be of interest. All my Z-Wave devices are unresponsive but power reporting and status still works - #4 by bertabcd1234