Power change trigger no longer working

I'm attempting to find some assistance with a rule that worked flawlessly for most part of the past year.

I have two Rule Machine rules for my washer and dryer, which are plugged into two separate KP125 energy monitoring plugs. The rules used-to trigger on a power change greater than 50 watts and send a Pushover notification at the start of the cycle, followed by a wait command for when the power dropped to 3 watts, and then announce the end of the cycle on Echo speakers and send another Pushover notification.

This has stopped working in the last few weeks and not sure if it's firmware related. I looked at the events and logs for the rules and they show that the power usage is changing on the devices and linked to the RM rules, but it never executes the actions for it.

Screenshots below:


I've posted this in the Kasa integration, and the the developer stated it's something to do with rule machine. Any insight or assistance as to how to troubleshoot this would be great.

Do you have all logging for this rule enabled? (I think there's a bug in the current release that prevents the "Trigger:" log entries from being generated, but normally they'd be there too if there's a matching event--along with action logs since there was a trigger, which are indeed missing from yours.)

One thing you could try: hit "Done" in the rule to re-initialize things and see if that helps. If not, make sure you have all logging enabled, and see if the output still looks like the above next time you have a matching event.

As a side note, I don't see anything about a power change in your trigger, just the raw reported power level. That level is also 5, not 50, though perhaps you changed this for testing? (This is a bit lower than I'd use with such a rule normally, but I suppose it does depend on your exact machine and the reporting behavior of your plug.)

You are correct, I did change it while testing to see if it's too high, and forgot to set it back. I've had all logging options enabled in both rules since I first created it and was testing it. Haven't turned them off.

I spent hours fiddling with the rule, the integration, device configuration and observing the difference between these rule and my other energy monitoring rules that work as expected. My other rules use Power On as a trigger. While these rules requires power change as the trigger because the plugs remain On at all times.

I'm trying to figure out if I can somehow integrate a variable to trigger it using the app " : Device Active Tracker, Times and Counts", as a workaround.

I'm not familiar with that app. I would try my other suggestion first.

I have done so numerous times, updated the rule(s). Hit done on both actions screen and main rule screen.

Do you mean to disable the logging, hit done, and then re-enable the logging and hit done again?

I wrote up a test rule like this using my energy meter and 400w as the trigger. Will test if it works.

No, I was just thinking hit Done (or Update Rule, the same aside from not closing the page). If you don't have any log entries, it's probably not triggering, based on the lack of action logging, though the lack of trigger logs (again, I think a bug) does make that unclear.

I don't think there's a general platform problem here, however. I have a similar rule that worked as recently as yesterday:

Screenshot of similar rule

To rule out a Kasa problem (and I agree that's unlikely), you could try swapping the real device for a virtual device (Virtual Omnisensor can do power for sure, though there are likely slimmer choices...). You could also try re-creating the rule to rule out some odd/hidden issue there.

FWIW, I have two rules that I use w/washer and dryer and two Sengled Zigbee plugs. Both rules are triggered by power use reported by the plugs going above a set level (start wash or dry), and then act again and exit when power level goes below a set let (end wash or dry). The rules also include a required expression that the washer or dryer door must be shut for the power trigger to start the rule. (Mostly for my washer, which will intermittently draw power at odd levels even when the door is open.)

Both rules are working fine on .144, I've done multiple loads of laundry and haven't had any issues w/power triggers (at least in my usage) in the current hub FW.

Your rule being fairly simple, from the looks of it, you could try disabling this instance and create a new one from scratch, just for kicks.


I've re-written the rules and it seems to trigger now. I received the notifications, as expected.

I honestly, didn't think that would work. Going forward that'll be on my list of things to do to troubleshoot. Ty everyone for your assistance.

1 Like

Again it stopped working.

Both plugs are being are reporting energy and just stopped triggering the rules.

Maybe it's an RM bug? I'm on beta firmware, so not sure if it's related.