Possible issue with Groups app on the C8

I recently completed a successful migration from my C5 to my C8. It is connected via Ethernet cable and it's in the same location as the C5 had been. The migration went well but I have one minor problem (Minor only because I can circumvent it easily): the Groups app appears not to be working properly in that, quite often, when I attempt to turn on a group of Zigbee devices using the group name from the app, not all devices turn on. This is true whether a rule accesses the group, the Android app accesses the group or the web dialog accesses the group. If I attempt to turn on the same set of devices using the device names and a wild card term, such as telling Google to turn on kitchen lights rather than kitchen group, all works as expected. I experienced this years ago on the C5, and even changed some of my rules to list devices to turn on or turn off rather than use a group name, those problems diminished over time and were non-existent on the C5 with the current release. Any ideas? The audio in this video was ducked because I forgot to turn off Hey, Google support on my phone, but the sequence was that I walked into the room, only one light came on, I told Google to turn on the kitchen group, that didn't work, but when I told Google to turn on the kitchen lights, using the wild card (All device names begin with the room name), all worked properly. I can circumvent this by editing the rule to apply to all seven lamps individually rather than using the group app name, but I'd rather see the bug fixed, of course.

Any ideas?

are these z-wave or zigbee devices, or both...
If all zigbee, is zigbee group messaging turned on?

1 Like

The grouped devices are all Zigbee, and group messaging is not turned on in the Groups and Scenes app; I've tried it over the years and found that it seems to cause problems, just like the problem I'm experiencing, now. But, as I say, it's not turned on. In the app, it suggests turning that off or turning metering on, which I tried, but that had no good effect.

have you tried group messaging on the c8?

Yes, and that doesn't help this issue.

maybe enable metering?, try 50 ms

I thought both radios had hardware flow control on the C-8? Rendering metering unnecessary?

All true, but obviously there's something at play here from an environmental standpoint as group messaging isn't working, not on a C7, or a C8...
So there's no harm in trying to slow things down a bit to see if it makes any difference.

1 Like

For sure. Makes sense.

Done. I enabled it on just the kitchen group. I can see the lights now coming on one at a time, but that's fine with me. If this solves the problem. I'll check back and let everyone know, just the satisfy curiosities.


So far, so good. Today, I think I'll try to shorten the delay a bit. Now, we need only determine what is causing the problem in the first place, keeping in mind that the C5, with the same device configuration, didn't have this problem (with metering off).

Oops. I spoke too soon. Twice since I posted the last message, with the metered delay. Still at 50 milliseconds, I walked into the kitchen twice and all but one lamp came on, both times a different lamp.


At that point, back in June, I gave-up on this problem and resigned myself to wait until the problem is fixed. Well, as of build released yesterday, the problem has been solved.

After some thought and experimentation, I came to a tentative conclusion that the problem didn't have to do with groups but, rather was a failure of the code to keep track of all Zigbee commands processed and transmitted when a relatively large number of device requests was made at once (my morning routine, for example, or the kitchen lights). Metering didn't help much, possibly because by the time the metered commands were being processed, some had already been discarded.

But, no matter. All is working, now, just as it was on my C5 when I retired it three months ago. I still love this platform despite three months of uncharacteristically quiet frustration.


1 Like

Iโ€™m glad itโ€™s now working for you, but Iโ€™m curious if there were any changes to the Zigbee stack. @mike.maxwell

Nope. No changes at all aside from factory resetting and rediscovering a few Zigbee devices during the experimentation stage. Before build, from the day I unplugged my C5 and restored its last backup to the new C8, there were no changes in the device cohort. All worked fine on the C5 in June, Zigbee had these issues from the moment I started using the C8, and with installation of ...134, all issues simply disappeared.


The Zigbee stack is the software on the hub that communicates with the Zigbee radio. I think there would have to have been an update to that for this latest hub update to have fixed your issue. If not, maybe there was some sort of corruption on the hub that was fixed by the update?


nope, none in 2.3.6

1 Like

Ah. I wasn't aware of the term.