Possible bug: Advanced Zigbee RGBW Bulb driver no longer going "on" after SetColorTemperature


I have a Sylvania BR30 RGBW bulb (LEDVANCE 1189-001B-00102428) controlled by Room Lighting via two motions sensors. It's been working fine like this for over a year.

Sometime within the last month (or so), the light started being left on, so I think some bug has been introduced in the Advanced Zigbee RGBW Bulb driver sometime in the recent few 2.3.8 builds.

I was going to post logs from the RL rule, but I was able to reproduce the issue with just the driver page. The hint was that the last thing RL does is issue SetColorTemperature - then I'd find the bulb still on but the current state of switch as off.

Reproduction steps:

  • The bulb is off.
  • On the device page, I click Set Color Temperature(2700).
  • The bulb indeed turns on and but switch stays unchanged as off.
  • If I then click Refresh, switch updates to on.
  • Alternately, I before hitting Refresh I can also hit Off, which turns off the bulb.

I switched the device Type to "Generic ZigBee RGBW Light" and now clicking Set Color Temperature(2700) no longer causes the bulb to turn on. I think this will solve the problem of RL leaving the bulb on.

Yes, using "Generic ZigBee RGBW Light" has fixed the light being left on. So I definitely question the behavior of "Advanced Zigbee RGBW Bulb".

That looks totally unrelated. I would suggest you create a separate post.



@jlv I am glad to find this as you told my problem word for word. The RL rules {2} I have had been working fine until just a few days ago and it has been driving me nuts. Only difference is my driver is the Advanced Zigbee CT Bulb. After reading what you wrote I went thru your reproduction steps with identical results. I had changed to the device driver, cleared everything and went back, still no good. Last night I changed to the generic zigbee CT bulb and Dont remember for sure, but something did not work right with it. Any advice you can give me? Does the driver need attention?

To be specific, I first changed it to "Device", hit save, then used "Delete All Current States" and "Delete All States", and then I changed it the Generic Zigbee driver, hit save, and then hit Configure.

1 Like

I did that as well, and just did it again. Now I have the generic zigbee ct bulb as the driver. Think I was frustrated last night but it appears to work OK. the switch on the device page is correct with the light strips state. Will check RL motion rules later as they also work off times and illuminance and my wife is also working in the kitchen where they are controlled with linptech presence sensors. I dont want to tell her to get out and go back, etc. Will update later.

@jlv My 2 RL motion rules are working fine now. Should someone be notified to fix Advanced Zigbee CT Bulb and Advanced Zigbee RGBW Bulb

1 Like

@mike.maxwell This seems to have been introduced in a recent release.

1 Like

Can someone specifically state which actual device driver combination isn't doing what?
At this point I'm unable to determine if the issue is the driver or a specific instance of room lighting.

I created this thread because I had a Sylvania/LEDVANCE bulb that was using Advanced Zigbee RGBW Bulb start misbehaving. It worked fine for a long time, then in a recent release my wife reported the light was no longer turning off.

At first I thought it was an issue with RL, but if you look at my reproduction steps in the first post, it this was totally reproducable with the device page.

Just clicking Set Color Temperature(2700) physically turns the bulb on, but leaves the switch state as off. Hitting refresh causes the switch state to update to on.

Changing the driver to Generic ZigBee RGBW Light makes the bulb behave again.

(According to the logs, last thing RL does to the bulb is use the SetColorTemperature API; I guess it then sees switch being off and doesn't turn it off, which leaves the bulb physically on.)

I'll send you a PM with two video files reproducing the driver problem.

1 Like