Possible Basic rule issue on

Similar to a recent thread I posted, today my Office light basic rule misfired.

In both cases, the light involved is a Zigbee Sengled Element Classic bulb.

The rule came on at 7:30 AM at 50% and switched to 100% at 8:00 AM
At 4:30 PM it's supposed to drop back to 50% and then turn off at 5:00 PM.

Today the light turned off at 4:30 PM instead of dimming.

In the upper floor where the hub is, there is an Ikea Tradfri bulb, 2 Tradfri outlets, and a Sonoff Zigbee outlet acting as repeaters.
In the basement where the office is, there are 3 Ikea Tradfri bulbs and a Tradfri outlet.
I think I'm covered mesh-wise.

Not sure if there is a hub/rule issue or I've got a temperamental bulb.

Please turn on logging for both the device (Description text logging) and the rule.

It would be helpful to capture a screenshot of the rule's App Status page at some point between 8:00 AM and before 4:30 PM.

Meanwhile, I will investigate and see if I can find similar behavior...

BTW, dimming the light to 50 would turn it on, you don't need to turn it on first.

Update: I made two different rules just like yours, only using 1 minute apart for each of the times. Each did exactly what they were supposed to do. So it is somewhat a mystery what is going on with yours. Really need the logging to see...

It is certainly odd.

I've enabled the logging as you recommended.

I also updated the rule to remove "turn on, then dim" (carryover from the 4th generation Echo routine I was using).

I have another rule, also for a Sengled Element Classic bulb, that is supposed to come on at 50% and then drop to 25%.

Looking at it's event logs, sometimes it comes on at 50% and then drops to 25% as expected, other times it comes on at 25%.

On the 10th, 12th, 13th, and 15th it came on at 50%.
On the 11th, 14th, 16th and 17th it came on at 25%.

I wonder if I should should change them to use the legacy driver instead?

Here is the rule status screen after 8:00 AM

Light schedule worked as expected today.

For the last two days (24th & 25th), the light has turned off at 4:30 PM instead of dimming to 50%.

Here is the log events from the 21st (when it worked as expected) and 24th where it didn't work.

Did you look at the app logs? What do they show for 4:30 PM?

Here's the 4:30 logs.
I have no idea what's going on here.

I don't either. Remove that rule and recreate it. Next time, post logs by screenshot, not copy/paste.

Swapped out the text for an image.

It's been a week.

I completely removed the rule and recreated it with a different name (did the same for the other two rules as well).

The Office rule worked fine until today, when the light shut off ahead of schedule, tons of weird log entries again.

I have another topic on here about a different issue (lots of ResumeX entries in the schedule).
This particular rule also has lots of ResumeX schedule entries (all my time based rules do).

Any ideas on what to do next?

Sent the info in to the support address.

There's another member here with similar issues, so now I know it's not isolated to just me.