Porting SAGE Doorbell Sensor Driver help needed

I did some work on the driver from the OP. Someone else, that I can't seem to find to give proper credit, converted it to HE. I just added parameters to save custom names for each contact for logging purposes.


Thanks @HAL9000 , I moved it to a properly named directory. You can remove yours.

Thank you for updating the DH code. I updated the original GitHub link.

I'd like to thank @lmosenk and all the devs here: the driver contained in the latest HE firmware didn't work for me, this one does, and it's also more configurable.

I spent 3 days trying to make the sensor work, but the problem was not the cabling or the sensor, it was the driver. As soon as I changed to this one, it worked immediately and flawlessly. Finally my Aeotec Siren 6 is doing its job. I completely replaced my old traditional doorbell and its old chime, with a new videodoorbell and the Aeotec Siren 6. HE is doing its magic. :slight_smile:

I'll tag @mike.maxwell to let him know about this, maybe he can take a look at the official driver and this one.

Thank you so much!

1 Like

the device and driver worked as intended when I built and tested it, so without a lot more info as to what didn't work, there's not much for me to go on here...

I read other users complaining that the default driver didn't work (@steve.maddigan):

What happens is that after the factory reset and the pairing, the first couple of rings were intercepted, then it stopped catching other ring events. I tried removing and inserting the battery from the sensor, but it still didn't work. If I factory reset and pair it again, it does the same thing, it works at the beginning, then it stops working.

What I noticed is that when it stops working these State Variables are shown under the device page. When it works they are not present. Also, I didn't understand what the "Configure" button does there.

Hope it helps Mike.



Yup it is true.

I didn’t install the sage doorbell until it was supported with in HE but I had purchased it based on this thread so I knew alternate drivers were out there.

I wasn’t sure if it was my wiring or not. I have a pretty old gear driven four chime door bell and I had to add a cct to pulse stretch the doorbell press so initially I thought it was my fault.

Connecting it directly to the transformer would get it working and by the time I reconnected it to the doorbell it would work once then nothing. I mean how hard can this wiring be?? It’s a doorbell !!

Anyway, tried the other driver and bingo.

Tried the built in driver again, hit config, worked a couple of times and nothing.

Went back to the other drive and we were good to go. I never looked back.

One of my biggest gripes with the internal apps and drivers is you don’t have any visibility. I’m not opening the can of worms again but just saying.

Same reason why I do not use HSM for my leak sensors. It don’t work after being disarmed once so I wrote my own rule to handle them.

Some day I will figure out how to write apps but that hasn’t happened yet.

1 Like

Thanks for sharing your experience Steve, pretty much similar to mine. I spent 3 days because I thought it was the wiring, but it turned out it was the official driver. :slight_smile:

I'll have another look at this.

1 Like

Thank you sir.

I've used both drivers with no issues with either. I switched to the present Hubitat native driver when it became available to stay with native Hubitat drivers when they are posted. I saw no difference with either driver. I do only have it connected to just one doorbell, my front doorbell and NOT any back. Hope that gives some incite to clearing up any issues.


Thanks a lot Mike.

Yes I only have the front doorbell connected as well.

Did you try changing the "Device preferences" to 5 verses 10? Somewhere I read someone was having multiple ring issues and he change his to 5 ( which I've also done) to correct the problem.

The driver is working pretty good @lmosenk , but I see these errors every once in a while in HE's log:

I don't know if it's a serious error or not, nor if it only happens to me.

Hi @alexdelprete,

I am not certain of the source of the error. I am using the exact same code and have not seen any undue side effects.

Has anyone been able to get a battery report from the Sage Doorbell sensor. I see drivers with the battery capability remarked out and the built in driver has no battery references.

Perhaps this device does not report battery?


Pretty sure I have read it doesn’t provide battery reporting. I ended up hard wiring mine since I installed mine in the crawl space by my transformer.


Thanks for the response. Actually I shouldn't have limited it to battery. What I really need is some periodic "heartbeat" to be sure the device is still there and working.

I don't know if Zigbee has on in its basic report.


Hi - I know I'm not supposed to ask for anything on a beta driver, but just looking for a bit of info.
I set up a sage sensor - works for the front doorbell but not the rear. I'm assuming it's either a bad sensor or something about it being a shorter chime response. The actual chime works for rear doorbell, but sage doesn't pick it up. I'll probably just order another but curious if there's anything about driver that could relate.

Also - what does Enroll Response button do? Is it something I need to do as part of setup?

I apologize if this should be obvious.