[PORT] Gentle Wake Up


#21

For this many min > 10
From this level > 5
To This Level > 99


#22

I'm getting the same thing. Duration 5 minutes, from 0 to 99.


#23

@hike20 Are you testing also? How far out are you triggering the lights from the 5 mins duration?

I'm not sure and still testing but I have mine at 10 mins right now. I think if the lights don't go on and I retest, I have to put it more then 10 mins out again. Not sure how this works.


#24

Just created a child app that "dims" from 5 to 99 over 10 minutes. It runs with no issues or errors in the log. Perplexing! If it helps any, I'm using version 2.0.0 of the parent and child apps.


#25

@aaiyar I just downloaded and installed this app yesterday so I'm hoping it's the latest version.

I have a test that will run in 3 mins from now. I will keep ya posted.


#26

I am on version 1.0.3.

I have a GE Z-wave plus dimmer ramping from 1%-99% over 30 minutes. In fact, I have two of these apps. One runs certain days, and the other runs on alternate days. They both fire and work great.


#27

Did it again. This time I waited over 30 mins to clear anything.

If I set a time of lets say 10:15am And it works, I will reconfigure and set at 11:00am and then I get the error and it wont work.


#28

@aaiyar Are you changing the time it runs? That is what I'm doing in order to test this.


#29

No. I'm using it differently, and that could be why I'm not seeing the error condition that you are.

I created child apps for each dimming routine that I want. These child apps appear as switches to Hubitat. So from Rule Machine, I simply turn on the child app that I want with the trigger condition that I need. I am using Gentle Wake Up only to create dimming over time child apps. I'm not using GWU to schedule when the child apps run.


#30

@bptworld

I'm I not able to readjust the time on a Child app? I've been trying to test and I would create a new Child App that is set to trigger at 8am. Ok worked. Now I change the 8am to 8:30am. I get error in line 673.

Delete that Child App, create a new one and set to trigger at 9am. Worked. Change trigger time from 9am to 9:30 Fail again.

I guess you just cant make a change to a child app? If not it's ok I just need to know so I can STOP testing.


#31

@basic261, you should be able to change anything at anytime. Please screenshot your child app so I can try to reproduce.

thanks


#32

@bptworld

Again if I had this set for 1:00pm it will work. If I go in and change the time to 1:30pm that's when I get the error. Here's the screen shot


#33

@aaiyar
So you are just basically creating a child and selecting which dimmer for how long and the dim percentage nothing else in that app saving it and then going into rule machine and creating a rule using that switch correct?


#34

Yup. Exactly that.


#35

@aaiyar I'm giving this a try.

I just have a Child setup with with Dimmer I want, How Long and the % of dim. Nothing else

Created a new RM
At XX:XX
Turn on Child
Delay 6min
Turn off.

Is this how you're doing it?


#36

All you need is:

At XX:XX
Turn on Child

The Child will automatically go off when it is done running (i.e. length of dimming period).


#37

Cool,

Just made the change

At XX:XX
On Child...


#38

Just bear in mind that you cannot turn on the child switch a second time through RM while the first run is still running.


#39

Right,

The test is running right now. Light is on and dimming to 100. Almost complete. Lets see if it turns off.

If it does, I want to change the time on the RM and test again. That's where I've been having issues.


#40

@aaiyar Ok test is done but light did not shut off. Do I need to add this in the Child