Poor range ! )

All my devices worked fine until I upgraded to on my C7 hub. After this, my two devices farthest from the Hub do not respond (Zigbee). They work fine if I move them in 10 feet or so, so devices are ok. I'd like to move them back.

Was there any change to the Hub power with this release?

Any suggestions or settings I can try to get range back?

Have you looked at the Zigbee power settings screen?

Screenshot 2023-10-12 at 8.51.47 AM

1 Like

That's a C-8 only thing, isn't it?

Yes, but the OP didn't mention their hub vintage.


@user1941 - do you have a C8, C7, or ? FW updates should not have any effect on Zigbee range...that's subject to your Zigbee mesh/devices which haven't changed.

Have you tried simply shutting down your hub (Settings>Shut Down) pulling power (best at the wall to avoid stressing the USB port on the hub), wait a minute, and then plug in again? If not, give that a shot.

Also, if your two Zigbee devices are experiencing some communication issues may just want to let things sit for a few hours and see if they check back in.

Could be another device maybe not even a smart home device causing interferance could even be your neighbors wifi.
But if it is the Hub firmware have you tried rolling back to older firmware through the Hubitat Diagnostic Tool to confirm that it is a firmware issue?

I have noticed a similar issue since upgrading to on my C7 hub.

I have 3 Zigbee Centralite 4200-C plugs in the basement which are all triggered by the same events, yet since the upgrade 1 or 2 of them is not responding occasionally. It is very inconsistent. They are the furthest Zigbee devices to my hub (on the 2nd floor), but are all direct connections to the hub. Prior to this last upgrade, I have had no issues with them for the last 3 years.

I unplugged all 3 plugs for a few minutes and then reconnected them which did seem to help for a bit, but my wife complained that one plug did not turn on again yesterday. I have not had a chance to further diagnose the issue or try powering down the hub for a while to force the Zigbee mesh rebuild maybe?

When I saw this thread, I figured I would add my experience so far to see if that helps.

Try the shut down/restart process I suggested above. Not the full Zigbee panic, but the short shut down/pull power/wait 1m/restart process.

As noted above Wi-Fi can interfere w/Zigbee radios, so if you (or even neighbors) have made any Wi-fi channel changes recently that can cause issues.

1 Like

Thanks, did not know this option existed!!! Any issues increasing power?

Good idea. I did reboot but now will try full shutdown.

Thanks to all. Will try suggestions tonight.

On comment was to allow Zigbee network to "rebuild". How long does a hub need to be powered off to force this rebuild?

Yes, potential for issues, with more power you also have a risk of accepting more interference. So you want it as low as possible while it still works. The C7 is fixed on roughly 8 and that is the default on the C8 now as well.

I was always told about 20 minutes and that's what I have used in the past when rebuilding the zigbee mesh.

1 Like

You can use the Rebuild Network option on the Zigbee Details page.

After the rebuild completes, use the Reboot Radio option (clears up some potential issues w/Zigbee mesh after using the Rebuild option).

I have the C7 Hub. I go into Settings, and then Zigbee details.... but my screen does not look like the one csteele showed. I seem to have now "Current power level" option. How do I get to this setting?

Screenshot 2023-10-12 182840

that is only on the C8 hub

1 Like

Thanks again to everyone!! Issue seems to be solved via the shutdown/power-on process of via updating the mesh. Either way, I'm running.
Have a good day, all.