Platform update available - won't update?

New to Hubitat so sorry if stupid question.

I have a notification that an update is available. I downloaded the update. And the notification didn't go away. I rebooted the hub and notification is still present.

What is the correct way to complete this?

When the update downloaded, did you see it decompress and install, then automatically reboot the hub?

The update process is, um, lacking in good feedback. In a short time owning the hub, I've found that about 1/4 of the updates succeed -- the download step seems to be 100%, but most of the time nothing happens after that. Some of the apparent failures are due to a combination of poor feedback + user error -- there's a long pause after the download with no progress information, which caused me to behave as you are describing -- rebooting the hub too soon (or restarting the download), only to find that the update hadn't been applied.

My suggestion is to wait.

Wait longer than you think.

Wait a touch more...and hope that you see status updates about uncompressing & installing the update.

The latest update did go a bit faster for me and there seemed to be better feedback, so perhaps that has been improved already.

1 Like

No. Just said download complete then nothing.

Will keep waiting. Thanks

If the issue does not clear up on its own, I’d recommend you contact

Sometimes I update and next time I check, there is a second update to correct bugs from the first update.

This led me to believe at first that my updates weren't going through but really updates were coming out that fast.

I agree some better feedback is in order. But I think that helene7t7 has it right. There are a couple of minor bug fix updates that follow on to the regular update. So if you weren't watching you missed the re-boot and that it's in fact a new update pending.

... at least it isn't finding anything new and it appears to be "updated" now. :wink:

I have been unable to do the last 3 updates that have been released. My hub downloads the update and sits at verifying download (or something to that effect) and stays that way until I reboot it.

Last night it sat for over an hour in this state. Should I wait longer?

No, it should not take more than ~5 minutes. I believe you should submit a case to

Have you tried rebooting your hub first, and then performing the update? That normally resolves the issue. If not, contact Hubitat support via email and they'll get things sorted out.

There is another trick you can try:

got to http://hub-ip:8081
click "restore previous versions" and see if the latest version is listed there. If it is, click it. That was mentioned in the last Hubitat Live as a workaround for your issue.

Thanks! I will try these tonight. If not successful I will open a case.

No luck with any of the suggestions. I tried to install tonight and it never gets past verifying download. I have opened a support case.

Then I would contact

And tell them in your email what you have done so far. This way they won’t ask you to do it again...