Pico Remote - I'm doing it wrong

I'm trying to get a Pico remote to work in Hubitat. The remote has been added to my Lutron Hub Pro. I have added the Pico into Hubitat via the Lutron Integrator. For now, I merely want to understand it so I set up a temporary test but haven't had any success yet. I set up a new Simple Lighting Rule. Can I create a Simple Lighting Rule to turn a light off with a Pico? Here's what I have now that's not working.....

What you have above is when button 1 is "released". The light is set to "ON" at 100%.

Here is an example of button 1 pushed will turn the light off.

My problem is that the release of the button does not turn the light on. I have tried every button (but I believe button #1 is the top button on the Pico). I gather from your reply that my problem lies elsewhere, ie not in the way I have this lighting rule programmed?

The Pico is present in the Lutron app but not set up for any function. Is that a problem?

I have successfully turned on a light in the house using the Pico while using Lutron's app. This tells me that the Pico works, the integration of the Pico within Lutron's app works leaving something to do with Hubitat. At least that's my logic.

Nothing wrong with your rule. Just that I thought you want the light off.
What driver are you using for the pico in HE? Lutron fast pico?
Open the live log and do your test. This way you will know what's happening.

What type of PICO do you have? 3 Buttons, 4 Buttons, 5 Buttons? If it is anything other than 5, go into the device and change the number of buttons and hit save

And try it again.

Also, can you show what device type was selected and the network ID? Like this:

Ok, the driver and the DNI match. Let's see if there is anything captured on the telnet channel

The Lutron Integration added a device call "Lutron Telnet"

Go into that device and enable "Enable debug logging" and hit save

Once you have done that, go to "Logs" in Hubitat and press a button on that Pico.

Post a screenshot of what you can see in the logs after you press the button

Well, that explains it, you don't have a telnet connection. Two things to check

  1. Did you enter the correct IP address for your Lutron Bridge in the Lutron Integration app?
  2. Did you enable the "Telnet Support" in the Lutron App under Settings->Integration?

My bet is on item 1 as I can see the error message "No route to host" in the log

1 Like

That fixed it. Couldn't have done it without you. The IP address for the Lutron Bridge was the problem. I set all this up a couple of days ago but read earlier today that not only should the HE's have a static IP address (which was already done) but so should the Lutron Bridges (I have 2 of each). As a result of reading that, I set a static IP for the Lutron bridge - which was not the IP address I had entered into the Integrator. IP address updated. Problem solved. Thanks!!!!

1 Like

Glad to see you got that figured out! I did notice you have the light set to turn on with the released event. With the Fast Pico driver that you're using, a pushed event will be generated as soon as you press the button, and released will not be generated until you let go. This means that unless you're planning on using pushed for something else, you could re-do this to turn the light on with pushed instead, and it will probably feel a bit snappier to you. Either will work (unless you change to the non-fast driver), but I usually only use the "released" on the Fast driver for dimming buttons, where I'll send a startLevelChange on pushed and a stopLevelChange on released to get a "dim while holding" experience.

(Backgrond information: with the non-fast driver, you'll get a pushed when you release unless you hold it for a while, where you'll get a held and then a released; the "fast" driver is so called because it can send pushed as soon as you press the button without waiting to see if you're holding it, at the expense of you having one less action available.)

1 Like