[Physical] events not showing

It seems in recent updates... The event stream and logs don't show [Physical] events..
And therefore lots of switches don't update status etc and automations don't work.. seems to be a bug!

Since this is the first report I'm going to say its not a wide spread issue, but to try and help you we're going to need some information. Let's start with:

  1. Hub Model
  2. HE release
  3. which specfic devices are at issue (need model numbers and firmware revs)
  4. what device drivers are you utilizing with each device

The stuff @thebearmay, asked for would be helpful. Also a couple of things to consider, these are automations that worked in previous releases? I ask because physical updates do not work on all devices, it is device dependent, thus the need to know the devices you have seen this issue on.

Another issue I found many revisions back and don't know if it was fixed or if it is expected behavior, but physical updates did not work across hub mesh. I had some automations that worked fine when I had a single hub, then when I switched to two hubs these automations no longer worked and I found because the device I needed the physical event from was shared with the hub with the rule on it.

I ended up making sure any rule that needed a physical event was on the same hub as the device. There is a thread here on the forum where I asked this but I never got a response from anyone at HE.

This was some time ago, not too long after hub mesh was introduced, so maybe that is no longer the case.

1 Like
  1. Hub Model : C-7
  2. HE release
  3. which specfic devices are at issue (need model numbers and firmware revs) :
    GE enbrigten Switches
  • deviceType: 18770
  • zwNodeInfo: D3 9C 00 04 10 01 5E 56 86 72 5A 85 5C 59 73 25 27 70 2C 2B 7A 68 23
  • deviceId: 12343
  • inClusters: 0x5E,0x56,0x86,0x72,0x5A,0x85,0x59,0x73,0x25,0x27,0x70,0x2C,0x2B,0x7A
  • manufacturer: 99
  1. what device drivers are you utilizing with each device : both devices are using Built -in drivers for the devices showing this issue

Yeah up until 2.2.7 ..I can say for sure they worked... After that I installed the 2.2.9... and recently realized that some simple turn off rules that turned off a light when only another physical switch was turned off was not working so checked the logs.. and standing in front of the switch and physically turning the switch on and off was not showing up in logs.. and therefore the rules was not working either...
I already removed the hub mesh from the equation when I had realized a few months ago that [Physical] doesn't get sent over hub mesh

There are several built-in drivers that work with these switches. Try "Generic Z-Wave Dimmer" (exactly that) and see if physical events are seen. Of course, you lose ability to control LED behaviour and possibly some other things.

it is not a dimmer.. and I AM using the built-in driver only, it is not a custom driver. I was looking at other devices.. interestingly though.. some other devices are fine.. and showing [physical], and couple of others are like this switch.. I am considergin excluding it and re-adding it back.. to see if that fixes it.

Try Generic Z-Wave Switch then.

it seems like something is wrong with zwave devices.. I have another z-wave valve.. that is also getting stuck with status not updating... when I manually open or close the valve, even using the dashboard, the device opens/closes, but doesnt update the status on the device info page etc..
seems like z-wave related issue.. the updates since 129 have been problematic.. I am almost planning to revert back

my embrighten switches are working fine for physical events.. here is the info..

i have one in mich as follows and one in nh.. i am only in nh so can only test that

currently on

Yup. So "GE Enbrighten Z-Wave Smart Switch" is another built-in driver @nrm94ee330 should try. He hasn't said what driver he is using, but I know that at least one of the built-in drivers for these switches fails to report physical state change.

1 Like

I'm on 1.36 and using the "GE Enbrighten Z-Wave Smart Switch" drivers.. literally just toggled the switch (bathroom fan).. shows physical for me too.

I have had some issues with older Zooz V2 switches not reporting state but that's been going on for a while (pre 1.29) and I am slowly replacing those as I go along. The 3 GE Enbrighten's I am using are all working.

It's weird that the older fw works and the newer does not.. maybe run a Z-Wave repair? - I know there are mixed messages on whether or not to run a full repair but sometimes it seems useful..

I have an extra hub,, so used that to exclude this switch, and then re-included back on the main hub, and the [physical] is showing up even while using the same driver as before ( Generic z-wave smart switch).. and now I have updated all the automations to the "new" ly included switch..

what all I tried before doing the "switch-a-roo"..
(1) z-wave repair for the device
(2) full z-wave repair
(3) turn off/disable z-wave and shutdown hub and wait 5 minutes and restart hub
(4) changed the drivers to 4 different z-wave switches (in-built drivers)

none of them worked ! :frowning:
but finally excluding from a different hub and re-including in the original hub fixed the issue.... but I dont have any inkling why this was the case...

As I said I have other switches (same make model and firmware), which are working just perfectly fine without issues.. just this and a couple of other devices.... so will have to do the switch-a-roo routine on them as well !

1 Like

Just moving from ST to Hubitat and notice that the [Physical] events are inconsistently captured. GE Smart Switch does not show any Physical evets. One Inovelli Red Dimmer Scene does not show Physical events. An older Inovelli Smart Dimmer (no scene led bar) shows physical events correctly. I really how there is a a good solution as I have a lot of automation that are trigger by physically turning ON/OFF switches.