Philips Hue Dusk-to-Dawn Outdoor Motion Sensor - Lux reporting controls

I have recently installed two of the Philips Hue Dusk-to-Dawn Outdoor Motion Sensors connected to a C-7 hub running 2.2.5.131 using the Hue Motion Sensor driver.

On the device page I have set the Lux Reporting preference to Disable.

When I go to the events tab for this device, it is still reporting Lux values. It appears to be reporting every 5 minutes.

Is this a bug or a feature? If it would reduce system overhead, I would like to be able to turn off the reporting if I am not using it for anything. Is this something I can correct? Or is this a driver issue?

Please advise!

@mike.maxwell ??

Thanks!

The other one (same hub, same driver, as above) has the preference set to report Lux on a change in value of 100. It also appears to be reporting every 5 minutes.

Preference setting:

Event tab:

Mine is set to on 10 Lux change and it updates each 5 minutes.

Interesting, I have 4 of these all are respecting the preferences.
The lux interval of 5 minutes is fixed in the sensor, but it does respect disabled at least on device firmware 6.1.0.25261

How do I examine the firmware version of this device?

If you switch over to the driver named "Device", then click getInfo it will then be written to the data section in the driver details.

It's also working for me on 6.1.0.18912 (older).
You did click "save preferences"?
I get the firmware version by substituting "device" as driver, and hitting getinfo. Can see it on the device page or the log.

  • softwareBuild: 6.1.0.25261

I went back to the Hue driver on both sensors. Saved Preferences, hit Configure. On the Device page I had Lux Reporting disabled. The log tab shows Lux reports ever 10 minutes.

When I was experimenting before, it appeared to me that when I hit the Configure button, the reporting interval changed between 5 minutes and 10 minutes. In all cases I had the Lux Reporting device preference set to disabled.

Mine constantly report motion from the sunlight changes... So that drives me crazy enough. Was wondering if it was something to do with the lux reporting. Unlikely though.

I haven't seen that problem but both of mine are partially protected (one's on a porch and the other is on a carport) and they are on the north side of the house.

1 Like

Yes, mine are on the south side, and exposed. I have a Samsung Motion reasonably protected from direct sun being tucked up under a porch roof and it is rock solid. The ones for the yard are a different situation. But they work very well otherwise, like them a lot. Unfortunately I have to just shut them off early to mid day haha. Sorry go off track.

@mike.maxwell will confirm, but some of the built in drivers work differently with configure / preferences.

  1. "configure" might set default values only and not respect preferences. Typically only run configure after manually swapping a driver.
  2. when preferences are set and you "save" - that's when some drivers actually send preferences to the device.

So if you save and then click configure, you might be overwriting the preferences back to defaults.

You can probably confirm the behaviour of the driver by turning on debug logging, then saving. See if the log shows preferences being sent at that point. Then don't touch configure and see if the lux stops reporting.

2 Likes

Excellent information. I wondered about this but never asked - exactly what does "Configure" do and what does "Save Preferences" do. This may explain why some of my devices haven't worked the way I thought they should based on the way I thought I had configured them!

That seems to have been the issue. User error. I must have been hitting "Configure" after changing the preferences.

Thank you!

1 Like

That wasn't it. While both Hue Motion Sensors were not reporting Lux last night. Sometime overnight, without any intervention, they both started reporting Lux again. Haven't touched the "Configure" button on the device page for either one. Lux Reporting is set to "Disabled" for both. Bummer drag.

Download the Hubitat app