Pause Notification rule broke

I use a virtual switch I call "pause interior motion switch" to pause/resume motion notifications. It started acting up so I deleted the rule and recreated it in hopes that would correct it. No luck. I have attached a screen shot of the rule. Can anyone see an issue why it

You'll want to post screenshots of the logs when the rule is triggered.

1 Like

We probably also need to know a bit more about what/how you use the switch....

I looked thru the logs and there are no errors. I just am no longer able to pause notifications with a rule.
I created a virtual switch and placed it on my dashboard. When I want to pause a notifications, I turn the switch on. To resume notifications, I turn the switch off. Worked perfectly for months. I have created a new rule with a simple if statement that is triggered by a contact switch opens to pause notification, And another simple if statement that is triggered by contact close to resume notifications. These too will not pause/ resume notifications. The only way now to pause notifications is to manually pause within the notification.

It's odd the Use Required Expression is on but nothing is defined there. Turn it off and see if it works.

Edit - I just made a test rule with time as the trigger and it worked so turning off RE probably won't make a difference.


1 Like

attached is screen shot after turning virtual switch off then on.

Do you have all three options for logging turned on in the rule?

Here is a better log.

FYI I have the interior motion detected notification mannually paused

I've never used paused/resume rules as actions, but if it were me, the first thing I'd do is to simplify the rule. It has superfluous fluff in it. Turn off use required expression as a start since you don't have one. Then reduce the rule to something like

Trigger on Pause Interior Motions changes

If Pause Interior Motion is on then Pause rule
else resume rule

Here is screen shot of rule with switch on

Here is screen shot of rule with switch off

It's odd that your rule shows it is paused in every screen shot. At 08:40 it resumed the rule, yet when you turned the switch on 12 seconds later it still showed the rule paused.

Maybe open rule and manually resume it and then hit done and then try your switch again.

That is a problem.
Also, I went to run a diagnostic on hub and it asked for ip address of hub. After entering it the option to log in is still greyed out.

It should be asking for the MAC address, not the IP.

My bad. I didn't read instructions carefully.
This gets more corrupted with everything I try. After rebooting hub, I can no longer access hub from either of my mobile devices.

I power cycled the hub and now have access to hub with mobile devices.
But still no resolution for why I can not pause notifications via rules. Maybe database is corrupt?
I just ordered a new C8 pro. Maybe the hub is corrupt?

Thanks in advance for any suggestions.

The biggest question is when I run the automation by turning on the virtual switch, it pauses correctly and the rule app and the notification app show it paused. But when I turn off the virtual switch the rule app and the notification app still show paused. But opening up the actual notification, it shows not paused.

You can take a backup and restore it to clear this up. That process cleans the DB.

Those pages aren't dynamic. If you unpause the rule, you have to refresh the page then you'll need to refresh the page to see the status change...or, as you did, go into the rule which will also update the status.

Besides the perception issue with what the rule is showing, the logs you showed earlier suggested the rule is running perfectly fine. Is the automation that you're pausing still running when it should be paused?