Patched webCoRE for Hubitat (2018/09/09)

A minor milestone for me: I brought up the dashboard and the drop-down hub selector (top-left) offered me the choice of either ST or HE. Prior to this, it was a mystery to me how the dashboard URL knew to go to ST or HE. I had two tabs open, one for each; now I can choose which one I want.

Thanks for digging into it. Of course, WAF comes first :wink:
I’ll try to work a bit in this once I am back from my travel.

Yup, these are some things in webCoRE that I really appreciate since it makes it so much easier to manage both hubs.

I'm not able to reliably bring up the HE webCoRE dashboard. Is there a tried-and-true method?

The ST dashboard is solid, but it only gives the ST option in the upper left hub drop-down selector.

I have (several times) successfully gotten the Hubitat dashboard up and created pistons and even imported ST pistons. When it works, I think it usually shows both the ST and HE hub options in the top left. But, for instance, right now it's not possible. I registered the browser (again) and got this far:

.
From the HE app list, which looks like,
image
I click on any piston and it brings me to an HE menu where I click on View piston in dashboard. That gives me a spinning-forever webCoRE logo.

The last option webCoRE (dashboard) just goes to a dead page in HE that says dashboard but does nothing.

But, in a day or two, I'll try one of these approaches and it will work. I just don't know what the key is. Please give me any suggestions that you successful webCoRE folks might have.

@ ajayjohnm I’ve opened up a pull request to add non working items 1 and 2 as well as putting the recovery handler inline to what it was before the custom one was added in smartthings.

I looked into item 3 but it appears to be api level and doesn’t seem to affect the piston’s functionality.

There is another issue that I haven’t had time to look into, but since the ids in hubitat are numeric the location id can clash with a device id. In a fresh instance the location id will be 1 and the first device id will be 1 causing the piston editor to get confused and it will show the hub name instead of the device while editing the piston. Users can remove the device and re-add it in hubitat for a new id and prevent “1” from being used again causing a clash. This can probably be fixed in a code change as well.

4 Likes

I too started having problems with HE webCore yesterday. I was trying to move over my security piston and it had an issue while saving. It is pretty large but worked fine on ST. When I tried to save it on HE, it was going through the Saving Chunks 1 of xx thing across the top and never finished and stayed within the edit screen. Tried to save it again and same thing happened. I was stuck in the edit piston screen. It was getting late so I just shut down chrome and went to bed. Got up today and tried to edit a different piston only to find I couldn’t get into the dashboard at all. Just the webcore logo and the spinning thingy in the middle of the screen.

Some things I’ve tried:

  • bring up my ST side and register a new instance
  • logged out of ST side and try to register a new instance
    • Each time I get the “There was a problem loading the dashboard data…” Just like @CAL.hub
  • Deleted the troubled piston from within HE
    • Same outcome trying to get into dashboard as above…“There was a problem…”
  • Tried going into the HE / webCore / Settings and pressing the “Clean up and rebuild data cache”
    • Not sure if this does anything but it had no effect. Still get “There was a problem…”
  • Also tried rebooting hub. Thought I had it this time as it asked me for my password but then it sill went to the “There was a problem…”

webCore ST dashboard still comes up just fine, just can’t add a new instance. I have about 20 pistons that are still running in HE but I can’t add or change any of them.

***** Persistence pays off *****
I just rebooted my hub again, pressed the “clean up” button again and tried to get into the dashboard…success! Hopefully it will last but for now I’m in. I won’t be trying that piston again though. I think it might be too big. Going to break it into multiple pistons. Hopefully my ‘things I’ve tried’ will help someone else.


@jp0550: Fantastic work with these patches. I did some preliminary testing before merging your commit and can confirm that it works perfectly!
We are 2 steps closer to a perfect webCoRE setup, thanks to you :slight_smile:

Merged the commit and updated the OP to reflect the changes.

4 Likes

Maybe I missed it but … is there anyway to turn off the webCore debug comments in the log? Or at least trim it down, webCore puts out a lot of comments.

thanks

Yes. Go through the code and // out the lines with debug in it. :wink:

Anyone else having issues with webCoRE.
Mine keeps freezing. I have to log out and register an instance again.
3 times in the last week.
I appreciate we are in the early stages of this product but RM does not give me the functionality I had with ST.

There must be some combination of registration/login that is the magic formula, but I haven’t found it so at this point it seems random to me. Now, it’s working great for me - my pistons load quickly with (almost) full functionality and - for me the best sign of health - the drop down box gives me the choice of either the ST or Hubitat instance.

But, experience tells me that I’ll again be unable to see the dashboard anywhere anyhow. I tend to work feverishly on my poisons while I can, then take a break waiting for the magic to reappear. Wish I knew what it is that triggers the problem or solution.

The problem for me yesterday was none of my Away pistons ran. When I got home today nothing turned on as my Mode didn’t change from away.
Had to log out and back in to webCoRE a couple of times and then reboot the hub to get them back working.
Real shame RM doesn’t have more functionality.

1 Like

I am having exactly same problem. Rebooted hub last night. This morning can’t open dashboard again. One piston that supposed to run in AM did not work.

Oddly, i haven’t noticed any issues like these.
Am wondering if it has anything to do with the fact that I have both ST and Hubitat instances registered and available for switching via the webCoRE UI.

The dashboard and login issues did exist for me, before the latest update was pushed out by the webCoRE team (which is the version my GitHub is on).

Have you tried leaving the Hubitat logs open to see if any errors appear?

What version of webCoRE are you running.
Mine is v0.3.104.

Same

v0.3.104.20180323

Same here. That is the version I have posted in the opening post.

I feel that it’s a lot of focus on getting new/fixed drivers to work, but they should also start matching RM up to the complexity level of webCoRE. I believe that many of us has a complex rules engine as a deal breaker for this project.

“It doesn’t matter” if one gets webCoRE to work perfectly, when that again is in fact running in cloud.

“The deal” with Hubitat is, for me, that it is local.

1 Like

Only the webCoRE editing UI runs on the cloud (dashboard.webcore.co).
The actual pistons, once created, are all running on the black Hubitat box at your premises.
To test this, disconnect your hub and check if an existing piston will still trigger. (Which it will).

On SmartThings, the Piston processing is also done on the SmartThings cloud, unlike Hubitat.

2 Likes

Download the Hubitat app