Pairing with Gen 1 Iris Zigbee devices no longer seems to work: C-8 hub sees the button but cannot take it out of pairing mode

I have quite a few Iris (AlertMe) Gen 1 buttons and they have worked well until this time. For some reason, upon changing the battery in one, it had self-resetted and is now showing the blinking green light, indicating that it is ready for pairing. I recently upgraded to the C-8 controller and when trying to pair this button back on the mesh, it does immediately find it, but the button never goes out of pairing mode, and just keeps blinking. I think somewhere along the way, support for pairing of Gen 1 Iris Zigbee devices got broken. To test this, I took another Gen 1 Iris button that worked perfectly well on my mesh and performed a factory reset on on. Now: same problem on pairing attempt. The C-8 hub sees it but cannot make it pair. The button just keeps blinking. So I think there is something really wrong with Iris Gen 1 device pairing. Any ideas out there? Thanks!


Iris V1 devices not compatible with the C-8 (unless you migrated them from a previous hub; they cannot be reset or paired new). If you see the "Iris V1 Zigbee" button at all on the C-8, you are not on the latest hub platform, which I'd also recommended for other fixes.

As for the V1 devices, the only way to get them usable on the C-8 would be to pair them to another hub (or controller) and get them on the C-8 with Hub Mesh (or a similar option).

Sorry to be the bearer of bad news. :slight_smile:


Understood. So if I pair them with a spare C-7 that I have and use the hub mesh feature to link the C-8 and the C-7, then I can get these Iris V1 devices back on the overall system?

And many thanks for your super-quick answer!


Yep, that will work!


Super! I can do that! Thanks!


Bit of chat about it over here too.

The gist is that the Zigbee 3.0 chip from SiLabs used in the C8 appears to not be quite so backwards-compatible as it promises on the spec sheet, which seems to have broken pairing for Iris V1 devices.

Luckily mine mostly remained on my C7, but in my tests I had exactly the same pairing issue as you did. The Iris V1 devices will work and even continue to route traffic on the C8, but if they ever drop the re-pairing never completes.

This may be fixed by SiLabs in a firmware update one day... or maybe not. So keep your C7 and earlier hubs around for the V1 devices and use Hub Mesh, which does perform brilliantly.

I had the same issue with a V1 plug in outlet. C-8 refused to complete the install. Fortunately I still had (2) C-5’s. I made the mistake of updating one of them to .140. It would not let me install the V1 outlet either. Sooooo….., I fired up the second, kept the firmware at .105 and installed the outlet in seconds. Set up my mesh on both C-5 and C-8 and they cohabitate.
Now it would be nice if I could just pull the device over (migrate it) to the C-8.
But I am sure I am just wishing in one hand and sh!tting in the other.

Sadly, that will never work. This is simplistic, but basically the migration works by giving the new radio the MAC address of the old one.

1 Like

Found this as I have the same issue.
From what I've found here is it looks like it's better just to return the C8 as it doesn't play well with Iris devices.

No modern zigbee 3.0 radio/coordinator will work with Iris v1 hardware.


Looks like only option is to send it back.
Just as easy to use wifi devices.
Check on some other hubs and they don't work with preexisting either.