Pairing failure GoControl WA00Z-1 switch

I've tried 3 units of the Nortex GoControl WA00Z-1 switch. Two of them got to the point of being found ("Found Z-Wave 004") but then it hangs at "initializing". I could not get the third unit into pariing mode so it was never found.
Are these devices incompatible? I will also email GoControl tech support to see if they can help.

I don't see it listed: Compatible Devices Wiki

There's always the possibility that someone has tried it . . .

I tried some more with the device close to the hub and this time it worked.

The initializing part is pretty normal for battery powered devices. They only turn their Zwave radios on when they are triggered and once they have sent their messages to the hub, they shut down the radio to save battery. The hub usually can not initiate a connection with a battery powered device since the radio is off.
Some devices have a wake-up and check in with the hub to report things like battery level etc. There is usually a method to have them wake for pairing and configuring but that is normally quite a short time period (30 seconds or so).

Are these working well for you? Thinking of using same switch for the same reason (no neutrals)

Download the Hubitat app