Outdoor Lighting


#1

At my church, I created a rule so that the exterior lights would come on only on Wednesday nights (Sunset + 20 min to 9 pm) when we were there. However, I came over today (Wednesday) and they were on at approx. 4 pm and had apparently been on all day. Is my rule incorrect?

Log output:
2019-01-30 04:13:12.467 pm [info] Wed. Night Lights is now False
2019-01-30 04:11:43.443 pm [info] Wed. Night Lights is now False
2019-01-30 04:09:23.380 pm [info] Wed. Night Lights is now False
2019-01-30 12:00:00.417 am [info] Wed. Night Lights is now True
2019-01-30 12:00:00.175 am [info] Wed. Night Lights: Time of Day 12:00 AM
2019-01-29 09:30:00.115 pm [info] Wed. Night Lights: Time of Day 09:30 PM
2019-01-29 05:53:00.276 pm [info] Wed. Night Lights: Time of Day 05:53 PM


#2

it looks like the rule went true only on Day is Wednesday, ie ignoring the "time between" bit, so I would suspect the is the old issue with RM where if you add or edit Conditions, you have open them, check they look correct and click Done, even if nothing changes or looks wrong. Do it also for the Define Rule area.


#3

Thanks jon1. I did as you suggested and no change. Today (Wednesday), when I got here, all the exterior lights were on at noon and apparently had been since 12 am?? I wouldn't think this to be a very complex rule. Am I misunderstanding it or something? I guess I will just have to disable it and quite using rule machine all together. Frustrated.

Hubitat Elevationā„¢ Platform Version
2.0.4.118


#4

Sunset, with offset, Sunrise with offset: has been a recurring issue. I'd guess we've seen 8 or more attempts to fix over the past 4 - 5 months.

As a test, maybe you could use a specific time to replace Sunset + 20. If there's still a logic problem, the extra clue might help Support. (Sunset isn't gonna vary a lot over a week.)


#5

Alright, thanks, will give it a shot.
However, the below rule (which uses an offset from Sunset and Sunrise) seems to work reliably.


#6

Did you open both Conditions and Define Rule tabs and click Done out of both? Has your hub updated to the latest version? mine is on 2.0.4.118


#7

Yes I did. Hub currently has 2.0.4.118 (and now 2.0.5.114). I changed to a specific time as requested by csteele and that appears to work. So, something is wrong with using sunset/sunrise +- offset AND a specific day of the week. For me, using sunset/sunrise +- offset works fine by itself. Very frustrating that this remains unfixed but I have another separate support request from Jan 31st that is still unanswered. I got nothing but a canned response from support.


#8

What about keeping rule as is minus Wed in conditions but use day, Wed, as a restriction? That may work.


#9

Using Wednesday as a restriction works thankfully.
Thanks ritchierich.