Out of geofence but present?

Recently I am seeing that even we are away from home, for both mine and my wife's android phones, the Hubitat app shows 'out of geofence ' as expected but still the presence is showing as present. If the app is directly showing out of geofence, shouldn't it immediately report presence as not present for the mobile app Device?

If the mobile app got disconnected from the virtual device on the hub that represents your phone, then it will no longer update the presence attribute.

Do you send text notifications with the mobile app at all? Try sending a notification to your phone by using the virtual device’s settings page in your hub interface.

If that doesn’t result in a push notification to your phone, then the mobile app probably did lose its connection to your hub.

1 Like

Where in the app can I find the option you send notification? Are you referring to 'send geo event'?

Under tools, under notifications.. I can see list of recent hub notifications.

On your Hubitat hub, go into your list of Devices. You will find one for each of your phones. Open that device and manually send a Notification from the hub to see if it appears on your phone.

1 Like

Just tried and the notification came immediately to my phone via app

Check the geofence settings in your phone app, make sure the app has location permissions, has no battery optimization enabled, etc.

1 Like

App shows 'out of geofence'

Battery is set to unrestricted:

Precise location is enabled

Notification from app device is reaching the hub and back to phone

When i am away from home, as you may see, wifi app (sk phone wifi) correctly reports phone is not on network and hence not present. Life360 app is correctly reporting not present. But, phone app device (sk phone new) is still reporting present.


This happens to me all the time. Location works perfectly for a few days, and then starts not reporting after awhile. On mine though, if I close and re-open the Hubitat app, it does immediately report the location properly again for a period of time. I think it really matters how much I use my phone before the Hubitat app is snoozed in the background and it just stops reporting location.

I do use my phone a LOT. I am always on my phone :smiley:
I also do open hubitat app every few days.

Yeah, I have no way to verify it, but I suspect that is what is happening. The phone has just decided to snooze the app in the background, probably after some resources threshold is reached.

My wife has pixel 6 and facing the same issue. The battery section has marked the app not to get optimized. What else can i try? I have pixel 7 pro, wife ha Pixel 6a.

Yeah I have had a Pixel 2, Pixel 5a and now a Pixel 6a over the years and the behavior has always been the same.

The way I had to solve the problem was using ZigBee presence sensors on our keychains. With a RM rule that says if my keys leave, set my phones presence to away, or if the keys arrive before my phone reports it's within the geofence to set the presence to arrived.

Just use an alternative Geofence-based presence solution, which it seems you are already doing with Life360. I rarely use the Hubitat mobile app for anything. I use Apple HomeKit for Geofence-based presence and Pushover for notifications. Both have been extremely reliable.


A long time ago, I found that if my phone was switching from wifi to cell data at the same time I was exiting the geofence, the exit event would not be sent. I increased the radius just enough so those things didnt happen at the same time. That and selecting 'Verify location on network change" in the advanced settings has made the HE app presence about 99% dependable with our Pixel 6a's.

That's interesting.
Just now I tried a few things, and the presence indicater updated!

Here are the things I updated:

  • in Hubitat app settings, clicked on 'hub'. It showed me my current phone devices and I clicked on my current device name to tell it again which phone device to use
  • On geo fence advanced, disabled delay exit. I also set delay in minutes to 0. Lastly I disabled 'set Presence only in motion'.
  • them I came to previous screen and clicked 'send geo event'

I'll try these with my wife's phone too tomorrow and will report back


tried the same set of setting changes on my wife's phone, and it works!!
Now as soon a i move the geofence pin to test, the presence status is getting updated immediately.

next, will test this in real world while going out of house in a day or two.

1 Like

I really like this idea! I’m thinking if we had guests, I wouldn’t want my whole house to arm the security system if both my husband and I left for a bit, but some guests wanted to stay in the house. Giving them a fob would be much easier than telling them to sign up in an app. Then, I could always just add/remove those fobs in the rule. Which Zigbee fobs do you use?

I don’t use geolocation to disarm, but I would like it automatically arm since I end up always forgetting to arm it when we leave. We have spotty cellular signal where we live. Like, our dog’s Fi Collar sometimes says she’s 0.3 miles away from the house then immediately says she’s back in the house.

Sometimes my wife and I leave the house and my kid is at home. After scaring my kid once, with the house starting to announce "intruder alert !!" while she opened the door behind us, I knew i needed to find a solution.
The way I solved it is

  • by creating a virtual presence device "kids at home". When i need to leave kids behind, I click my dashboard to make that device "present".
  • My house does not get armed if me, my wife OR 'kids at home' are present at home, so this is good
  • Next, i have a Rule, which automatically flips 'kids at home' back to 'not present' after X hours

Oh this is a nice cheap solution. I started going down the path of looking for Zigbee Presence Fobs and only found the SmartThings Arrival Sensor at $20-30 a piece so I don't really think I want to buy like 5 of these lol. I may still get 2 for my husband and I since we have spotty cell tower service (rural area), then I'll just create a "Guests" Mode that includes this Virtual Presence Sensor and rules for the security (among other things).

I marked my own reply as a solution, but that has completely fixed the issue for both me and wife.